Upgrade 2.1.5 to 2.2.3



  • Hi,
    I tried updating pfSense via Auto Update(console and webinterface) but it doesn't work. It just restarts with the old version.

    In the Update Log this Error is shown

    /usr/bin/gzip -dc /root/firmware.tgz | /bin/dd of=/dev/mmcs2 obs=64k
    dd: /dev/mmcs2: Operation not supported
    

    The pfSense came with 2.1.5 preinstalled. The only thing I did since then was to restore the config from my old one.

    Would be nice if you could help me out. I already searched for this error in the forum but didn't find a solution.



  • Do not upgrade.

    Make a backup of your config.
    Make a second backup of your config.

    Do a complete NEW install - overwrite everything. do the partitioning, format, install.

    Assign your interface.

    You'll be having a clean pfSEnse setup. Setup the Internet access - your LAN should give you Internet acces.

    Now, import one by one (yes you can select parts of the backup config) your config back in.
    DO NOT do this to fast. - As soon as the imported part works, make a config backup.
    Import the next part.

    In case of doubt, just setup by hand every functionality you need.

    If thing go wrong, track back.



  • Thank you, will do.

    But… :D

    Can you point me in the right direction How to do a complete partioning etc.? Is there a tutorial for it?



  • Simplest way is to use the 2.2.3 installation CD or USB stick. Download the image you need from here: https://www.pfsense.org/download/

    The installation process will do all the reformatting for you.