Horribly slow COPY on SMB share



  • Hello.

    I am not sure this is related to this forum, but I think that it's the best place to post it.
    I'm having an unknown problem ever since I started working with pfSense (switched off FortiGate-60).
    My network is as follows:

    WAN (has no effect here, it's an internal network problem)
    LAN (FreeBSD 7-STABLE, Samba 3.0.28)
    OPT1 (Windows 2000 Server, Backup)

    All connected to pfSense through 3 NIC's and operating at 100Mbps.

    pfSense has a rule to allow traffic on port 445 (MS DS) from OPT1 -> LAN, with no states.
    All other OPT1 -> LAN traffic is denied (though no speed increase was monitored without it).
    There's no traffic shaping in effect at all.

    Using the above configuration, I am able to list files on the Samba share (LAN), and then I want to copy a 300MB file from LAN to OPT1. The copy takes around 160 minutes. That's a bit below 2MB/min. which sounds terribly wrong! The same hardware and software combination were used with the previous FortiGate-60, also connected to its 3 NIC's, and it ran pretty well! I guess it's something in pfSense's configuration?

    Thanks for your assistance in advance.



  • It might be your nic's (intel is best)

    File transfer with windows can be a pain so i prefer using something else.

    To test your speed you can use SMBdownloader ( no install )
    ftp://ftp.jcu.edu.au/pub/Utilities/other/SMBDownLoader.exe

    Total Commander is also a nice tool.
    http://www.ghisler.com/



  • pfSense uses fxp's (which are Intel's), LAN uses Broadcom's (it's brand-new HP 380G5 server) and OPT1 uses Netfinity (IBM x335 server).
    Again, everything worked with the former firewall… No hardware/software changed except the firewall.

    This is odd!!



  • And, it's a backup robot that is installed on the Windows (OPT1) server that automatically copies all data on the SMB share (LAN), so no other protocols or programs would fit my needs.



  • Trafficshpaing on multiple interfaces is not really supported in 1.2. Turn off the trafficshaper for your situation.



  • As I mentioned earlier, there's no Traffic Shaper active on any interface…



  • Anyone have any idea on how to solve this particular problem?
    Meanwhile, I've allowed all traffic on the firewall between these two NIC's, with no Traffic Shaping whatsoever, and I still get the same rate. I will probably connect both computers with a cross-cable eventually if this is not resolved… :(



  • OK, I think I've resolved this problem. I've done the following steps:

    1. Tweaked the Windows Registry using numerous HOW-TO's found on the Internet, especially TCP Windows Size, Request Buffer Size and TCP 1323 Options.

    2. Rebooted the Windows server.

    This has resolved the problem, and copying a 300MB file now takes approximately 2 minutes!

    Thanks for everyone's assistance and time.


Locked