2.2.1 -> 2.2.3: Darkstat constantly restarting



  • G'day  ;D

    After the upgrade this morning this floods my logs:

    | Jul 5 13:45:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:44:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:43:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:42:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:41:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:40:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:39:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:38:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:37:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:36:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:35:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:34:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:33:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:32:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 5 13:31:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |

    I rebooted the box an extra time, but that didn't solve it.

    Thank you in advance for any help,

    Bye,



  • Uninstalled darkstat this morning. 8 hours later I still see this in the log:

    | Jul 6 17:05:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 6 17:04:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 6 17:03:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) |
    | Jul 6 17:02:00 | php: servicewatchdog_cron.php: Service Watchdog detected service darkstat stopped. Restarting darkstat (Darkstat bandwidth monitoring daemon) [/t][/t][/t][/t][/t][/t]

    Can't be: I deinstalled you 8 hours ago.
    |



  • At the same time, Squid and Squidguard also randomly stop, as do Snort (LAN) and OpenVPN client.

    Not a good upgrade, 2.2.1 -> 2.2.3.

    I think I'll restore 2.2.1.


  • Banned

    Uhm… uninstall won't remove darkstat from Service Watchdog. Remove it yourself.



  • I just hit you with my fat karma stick, Dok  ;D

    It's 40 degrees here, that does things to your brain, obviously.

    I would have expected the watchdog to have some sort of integration, but obviously it has not.

    Still, that leaves Squid, Squidguard, Snort and OpenVPN client.

    I just restored 2.2.1, I have little doubt that fixed the problem, as 2.2.1 was running stable with all the packages for quite some time.


  • Banned

    Hmm, OpenVPN has been working just fine, beyond pointless restarts on some config changes - but that's nothing 2.2.3 specific.

    Proxy stuff => I won't touch. Yuck!



  • It's 40 degrees here, that does things to your brain, obviously.

    My A/C died on Saturday morning at the start of a heat wave here.  My bedroom was almost that hot at 11:30pm last night…  ok, I'm exaggerating.  It was only 31.5C.

    Proxy stuff => I won't touch. Yuck!

    Who knew???



  • Restored 2.2.1 last evening: been running for 17 hours now; all problems gone again.