"no carrier" with ixgbe after upgrade to 2.2.3



  • I did an upgrade from 2.2.2 to 2.2.3 and now one of the two ports of my Intel X520-SR2 doesn't switch on the gbic any more. After downgrading to 2.2.2 it is working again.

    The one port (ix0) which wasn't working anymore has only tagged vlan interfaces and no untagged vlan interface configured, I suspect the introduced patches with 2.2.3 are the culprit.
    I use the other port (ix1) for WAN without any vlans. This one is working with 2.2.2 and with 2.2.3.
    ix0 setup on master machine with 2.2.2:

    
    ix0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=8500bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwfilter,vlan_hwtso>ether 00:19:99:ef:49:c8
    	inet6 fe80::219:99ff:feef:49c8%ix0 prefixlen 64 scopeid 0x1 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (10Gbase-SR <full-duplex>)
    	status: active
    ix0_vlan85: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:49:c8
    	inet6 fe80::219:99ff:feef:49c8%ix0_vlan85 prefixlen 64 scopeid 0xb 
    	inet a.b.c.142 netmask 0xffffff00 broadcast a.b.c.255 
    	inet a.b.c.140 netmask 0xffffff00 broadcast a.b.c.255 vhid 27 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (10Gbase-SR <full-duplex>)
    	status: active
    	vlan: 85 vlanpcp: 0 parent interface: ix0
    	carp: MASTER vhid 27 advbase 1 advskew 100
    ix0_vlan82: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:49:c8
    	inet6 fe80::219:99ff:feef:49c8%ix0_vlan82 prefixlen 64 scopeid 0xc 
    	inet d.e.f.102 netmask 0xffffff80 broadcast d.e.f.127 
    	inet d.e.f.100 netmask 0xffffff80 broadcast d.e.f.127 vhid 28 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (10Gbase-SR <full-duplex>)
    	status: active
    	vlan: 82 vlanpcp: 0 parent interface: ix0
    	carp: MASTER vhid 28 advbase 1 advskew 100
    ix0_vlan151: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:49:c8
    	inet6 fe80::219:99ff:feef:49c8%ix0_vlan151 prefixlen 64 scopeid 0xd 
    	inet g.h.i.4 netmask 0xffffff80 broadcast g.h.i.127 
    	inet g.h.i.2 netmask 0xffffff80 broadcast g.h.i.127 vhid 29 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (10Gbase-SR <full-duplex>)
    	status: active
    	vlan: 151 vlanpcp: 0 parent interface: ix0
    	carp: MASTER vhid 29 advbase 1 advskew 100
    ix0_vlan128: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:49:c8
    	inet6 fe80::219:99ff:feef:49c8%ix0_vlan128 prefixlen 64 scopeid 0xe 
    	inet k.l.m.249 netmask 0xffffff80 broadcast k.l.m.255 
    	inet k.l.m.247 netmask 0xffffff80 broadcast k.l.m.255 vhid 30 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (10Gbase-SR <full-duplex>)
    	status: active
    	vlan: 128 vlanpcp: 0 parent interface: ix0
    	carp: MASTER vhid 30 advbase 1 advskew 100</full-duplex></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwfilter,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast> 
    

    ix0 setup on backup machine with 2.2.3:

    
    ix0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=8500bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwfilter,vlan_hwtso>ether 00:19:99:ef:4b:e6
    	inet6 fe80::219:99ff:feef:4be6%ix0 prefixlen 64 scopeid 0x1 
    	nd6 options=21 <performnud,auto_linklocal>media: <unknown type="">(autoselect)
    	status: no carrier
    ix0_vlan85: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:4b:e6
    	inet6 fe80::219:99ff:feef:4be6%ix0_vlan85 prefixlen 64 scopeid 0xb 
    	inet a.b.c.141 netmask 0xffffff00 broadcast a.b.c.255 
    	inet a.b.c.140 netmask 0xffffff00 broadcast a.b.c.255 vhid 27 
    	nd6 options=21 <performnud,auto_linklocal>media: <unknown type="">(autoselect)
    	status: no carrier
    	vlan: 85 vlanpcp: 0 parent interface: ix0
    	carp: INIT vhid 27 advbase 1 advskew 200
    ix0_vlan82: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:4b:e6
    	inet6 fe80::219:99ff:feef:4be6%ix0_vlan82 prefixlen 64 scopeid 0xc 
    	inet d.e.f.101 netmask 0xffffff80 broadcast d.e.f.127 
    	inet d.e.f.100 netmask 0xffffff80 broadcast d.e.f.127 vhid 28 
    	nd6 options=21 <performnud,auto_linklocal>media: <unknown type="">(autoselect)
    	status: no carrier
    	vlan: 82 vlanpcp: 0 parent interface: ix0
    	carp: INIT vhid 28 advbase 1 advskew 200
    ix0_vlan151: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:4b:e6
    	inet6 fe80::219:99ff:feef:4be6%ix0_vlan151 prefixlen 64 scopeid 0xd 
    	inet g.h.i.3 netmask 0xffffff80 broadcast g.h.i.127 
    	inet g.h.i.2 netmask 0xffffff80 broadcast g.h.i.127 vhid 29 
    	nd6 options=21 <performnud,auto_linklocal>media: <unknown type="">(autoselect)
    	status: no carrier
    	vlan: 151 vlanpcp: 0 parent interface: ix0
    	carp: INIT vhid 29 advbase 1 advskew 200
    ix0_vlan128: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3 <rxcsum,txcsum>ether 00:19:99:ef:4b:e6
    	inet6 fe80::219:99ff:feef:4be6%ix0_vlan128 prefixlen 64 scopeid 0xe 
    	inet k.l.m.248 netmask 0xffffff80 broadcast k.l.m.255 
    	inet k.l.m.247 netmask 0xffffff80 broadcast k.l.m.255 vhid 30 
    	nd6 options=21 <performnud,auto_linklocal>media: <unknown type="">(autoselect)
    	status: no carrier
    	vlan: 128 vlanpcp: 0 parent interface: ix0
    	carp: INIT vhid 30 advbase 1 advskew 200</unknown></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></unknown></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></unknown></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></unknown></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></unknown></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwfilter,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast> 
    

  • Rebel Alliance Developer Netgate

    There were some small changes to the ixgbe driver in 2.2.3 but that's the first I've heard of anyone having issues like you say.

    Did you happen to check anything else at the time? What is your current setting for kern.ipc.nmbclusters in /boot/loader.conf.local or system tunables? What does "netstat -m" show?


  • Rebel Alliance Developer Netgate

    You might also try adding this to /boot/loader.conf.local and rebooting:

    hw.ixgbe.allow_unsupported_sfp=1
    


  • I think I found the cause for my problems, I had still two tagged vlans defined in interfaces->vlans, but no assignment for them.
    After deleting these vlans my ix0 comes up again with 2.2.3.

    Thanks for your help jimp and I'm sorry for bothering you.



  • I just did the 2.2.3 upgrade and I'm having the same problem. Already checked and there are no VLANs unassigned, already tried the hw.ixgbe.allow_unsupported_sfp=1 and hw.ix.unsupported_sfp=1, the first one got the interface to ACTIVE state, but the media was always Unknown and It simply didn't pass any traffic, even with the vlanhwtag off.

    I'm out of options, anyone having the same issue?



  • Guys,

    I figured out what was the problem. I had Device Polling enabled, and apparently it was causing a unexpected exception in the driver.

    Turned it off, now everything is ok.

    Also had to turn the hw.ixgbe.allow_unsupported_sfp, considering that I'm using a DA cable.


Log in to reply