Pc Engines APU unit playing Half-Duplex with Juniper - Is this a hardware issue?



  • I think I have used APU with a DSL modem and I attained 50mbps few weeks back but today I installed a new APU which is NOT playing nice with a ISP provided Juniper router (fiber router). It's giving me half-duplex and hence very low and irratic speeds (3mbps to 1mbps). At first I thought it's the limiters because I was playing with those but even removing those didn't help.

    I factory reset pfSense 2.2.3 and tried again with WAN set to DHCP and not static and link again showed up as 100baseT and Half-Duplex. I forced the WAN port speed to 1000baseT and Full-Duplex but then it failed all together.

    Then I found this bug: https://redmine.pfsense.org/issues/3870

    This is really disappointing given I have bought quiet few of these and ordered few more and now this…

    Can someone please comment on this to tell me what this means? I am not sure how the issue on redmine ends. Am I supposed to not get even 100 mbps from this? should I go back to Alix2D13? How come it worked well with another router?

    Thanks,



  • Like the bug says, it's a problem with the hardware and there's likely nothing that can be done in pfSense to fix this.

    Though your issues is likely with the other end of the cable. Both ends should be set to autonegotiate the link. I'm thinking the other end is possibly forced to something or is failing to autonegotiate.



  • If only one side is set to autoneg, you may wind up with the speed correct but are almost guaranteed to have a duplex mismatch.  Sometimes you have hardware issues that get in the way.  Do you have access to the configuration of the Juniper?  If so, a quick check of the settings should tell you a lot.



  • @torontob

    • try out another (fresh or new) cable
    • or try out a so called crossover cable, but then both sides must be on auto mode!
      Helps me sometimes out with my MikroTik equipment to connect to Cisco routers or some modems.


  • For the future.

    Rule of thumb, never get anything with RealTek hardware, even if officially supported. Same for Broadcom. I do purchase devices with my blacklisted NICs only if I have an acceptable path to install a NIC of my choosing. Got a motherboard for my desktop with a RealTek, installed an Intel i210. My firewall came with a RealTek, installed an Intel i350.