Installation of freeradius2 FAILED!



  • I just updated to the 2.2.3-RELEASE of pfsense.

    Firmware upgraded proceeded properly, however when upgrading the related packages -  freeradius2 package does not want to install.

    Below is the error message displayed when I chose to install the package manually.

    I need freeradius for my setup, so would appreciate any suggestions on how to fix the problem and/or install an earlier version that does install.

    thanks

    Robert

    
    Beginning package installation for freeradius2 .
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading freeradius2 and its dependencies... 
    Checking for package installation... 
     Downloading https://files.pfsense.org/packages/10/All/freeradius-2.2.6_3-i386.pbi ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Include freeradius.inc is missing!
    Removing package...
    Starting package deletion for freeradius-2.2.6_3-i386...done.
    Removing freeradius2 components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file freeradius.inc could not be found for inclusion.
    Deinstall commands... 
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.
    
    Installation halted.
    
    


  • I have the same problem.

    Someone can help you?

    Thank you.



  • Beginning package installation for freeradius2 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading freeradius2 and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/freeradius-2.2.6_3-i386.pbi ...  could not download from there or https://files.pfsense.org/packages/10/All//freeradius-2.2.6_3-i386.pbi.
    of freeradius-2.2.6_3-i386 failed!

    Installation aborted.Removing package...
    Starting package deletion for freeradius-2.2.6_3-i386...done.
    Removing freeradius2 components...
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.

    Help Me!



  • pkg add  https://files.pfsense.org/packages/10/All/freeradius-2.2.6_3-i386.pbi

    Fetching freeradius-2.2.3_1-i386.pbi: 100%  27 MiB 454.8kB/s    01:03
    pkg: /tmp/freeradius-2.2.3_1-i386.pbi.XXXXX is not a valid package: no manifest found

    Eroor … (((


  • Banned

    @anzak84:

    pkg add  https://files.pfsense.org/packages/10/All/freeradius-2.2.3  _1-i386.pbi

    Totally broken idea in the first place. You do NOT install PBI sh*t via pkg.



  • I was able to reinstall the package today…. so all seems working now.



  • I'm on the same boat…

    Beginning package installation for freeradius2 .
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading freeradius2 and its dependencies... 
    Checking for package installation... 
     Downloading https://files.pfsense.org/packages/10/All/freeradius-2.2.6_3-amd64.pbi ...  could not download from there or https://files.pfsense.org/packages/10/All//freeradius-2.2.6_3-amd64.pbi.
    of freeradius-2.2.6_3-amd64 failed!
    
    Installation aborted.Removing package...
    Starting package deletion for freeradius-2.2.6_3-amd64...done.
    Removing freeradius2 components...
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.
    
    Installation halted.
    

    And here's what the syslog says:

    Jul 18 16:25:47 php-fpm[21496]: /pkg_mgr_install.php: Beginning package installation for freeradius2 . 
    Jul 18 16:26:08 check_reload_status: Syncing firewall 
    Jul 18 16:26:21 php-fpm[21496]: /pkg_mgr_install.php: XML error: no packagegui object found! 
    Jul 18 16:26:21 check_reload_status: Syncing firewall 
    Jul 18 16:26:21 check_reload_status: Syncing firewall 
    Jul 18 16:26:21 php-fpm[21496]: /pkg_mgr_install.php: Failed to install package: freeradius2\. 
    
    

    Any idea how to force the install via the command line?



  • Try installing it several times. Do you get same error every time?



  • The error message says it can't download the file.

    Just as a test, try downloading the package from a web browser, just to see if you can access it.  Use this link: https://files.pfsense.org/packages/10/All//freeradius-2.2.6_3-amd64.pbi

    I'm able to download the installation package at that link  If it doesn't work for you, maybe a firewall rule is blocking the download for some reason.



  • Thanks for the replies, guys. This is a clean install in VMware, nothing but internet connectivity and this is the first package I install. I have tried it multiple times on multiple clean installs. I can download the PBI and install it from shell using pbi_add, but then there is no GUI for freeradius on the web interface.

    Any ideas?

    Darkstat fails the same as well, I can install other packages.



  • i am also unable to install it . .
    i am getting
    it is stuck at below screen for the past 2 hours…

    Beginning package installation for freeradius2 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading freeradius2 and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/freeradius-2.2.6_3-i386.pbi ...  (extracting)

    if i reboot it wil be shown as installed but not appearing in gui.. removing and reinstalling gets stucked at above screen ..

    i am on nanobsd 4gb image.

    ram is 2 gb.

    tmp is 350mb

    var is 150mb

    it was intstalled earlier and i could do all sort of configurations but couldnt start its service .. as highliged in this thread https://forum.pfsense.org/index.php?topic=102837.0then i removed it for now unable to installl it ..


Log in to reply