Sarg + SquidGuard PFSense



  • Estou com um problema ao gerar relatórios pelo Sarg 2.3.6 no pfsense 2.1.5, tenho uma tarefa agendada na "schedule" do sarg mas ele não gera nada, e quando tento executar o comando sarg -x ele da o log abaixo:

    SARG: Init
    SARG: Loading configuration from /usr/pbi/sarg-i386/etc/sarg/sarg.conf
    SARG: Loading exclude host file from: /usr/pbi/sarg-i386/etc/sarg/exclude_hosts.conf
    SARG: Loading exclude file from: /usr/pbi/sarg-i386/etc/sarg/exclude_users.conf
    SARG: Reading host alias file "/usr/pbi/sarg-i386/etc/sarg/hostalias"
    SARG: List of host names to alias:
    SARG: Deleting temporary directory "/tmp/sarg"
    SARG: Parameters:
    SARG:          Hostname or IP address (-a) =
    SARG:                    Useragent log (-b) =
    SARG:                    Exclude file (-c) = /usr/pbi/sarg-i386/etc/sarg/exclude_hosts.conf
    SARG:                  Date from-until (-d) =
    SARG:    Email address to send reports (-e) =
    SARG:                      Config file (-f) = /usr/pbi/sarg-i386/etc/sarg/sarg.conf
    SARG:                      Date format (-g) = Europe (dd/mm/yyyy)
    SARG:                        IP report (-i) = No
    SARG:            Keep temporary files (-k) = No
    SARG:                        Input log (-l) = /var/squid/logs/access.log
    SARG:              Resolve IP Address (-n) = No
    SARG:                      Output dir (-o) = /usr/local/sarg-reports/
    SARG: Use Ip Address instead of userid (-p) = No
    SARG:                    Accessed site (-s) =
    SARG:                            Time (-t) =
    SARG:                            User (-u) =
    SARG:                    Temporary dir (-w) = /tmp/sarg
    SARG:                  Debug messages (-x) = Yes
    SARG:                Process messages (-z) = No
    SARG:  Previous reports to keep (–lastlog) = 0
    SARG:
    SARG: sarg version: 2.3.6 Arp-21-2013
    SARG: Reading access log file: /var/squid/logs/access.log
    SARG: Records in file: 0, reading: 100.00%
    SARG:    Records read: 0, written: 0, excluded: 0
    SARG: No records found
    SARG: End

    Já tentei reinstalar os pacotes, já tentei deletar e fazer de novo o access.log mas não deu jeito.
    Nem no realtime aparece alguma coisa.
    O que pode ser?

    Desde já agradeço,



  • Você está rodando os logs no squid ou no sarg?

    Aparentemente o arquivo não tem conteúdo ou pelo menos conteúdo no dia marcado no sarg.



  • @marcelloc:

    Você está rodando os logs no squid ou no sarg?

    Aparentemente o arquivo não tem conteúdo ou pelo menos conteúdo no dia marcado no sarg.

    No Squid mesmo..
    Mas se tiver outro jeito para funcionar por mim blz, só preciso fazer funcionar o relatório de sites acessados mesmo.



  • Desmarque a opção de rotate do log(tanto no squid quanto no squidguard) pra ter certeza que os registros que o sarg procura estão lá.



  • @marcelloc:

    Desmarque a opção de rotate do log(tanto no squid quanto no squidguard) pra ter certeza que os registros que o sarg procura estão lá.

    Desculpe a ignorância, mas aonde faço isso?



  • @gabriel25:

    @marcelloc:

    Desmarque a opção de rotate do log(tanto no squid quanto no squidguard) pra ter certeza que os registros que o sarg procura estão lá.

    Desculpe a ignorância, mas aonde faço isso?

    No proxy server deixe com zero o campo Log Rotate

    No proxy filter desmarque a opção Enable log rotation



  • @wesmp3:

    @gabriel25:

    @marcelloc:

    Desmarque a opção de rotate do log(tanto no squid quanto no squidguard) pra ter certeza que os registros que o sarg procura estão lá.

    Desculpe a ignorância, mas aonde faço isso?

    No proxy server deixe com zero o campo Log Rotate

    No proxy filter desmarque a opção Enable log rotation

    Não resolveu ainda :/


Log in to reply