Traffic shaper squid and squidguard



  • Hellow everyone,

    As I have tested and installed squid 2.7.9 squidguard 1.9.14 and enbabled traffic shaping only https sites works as they expected. As I understand traffic shaping with squid and squidguard not working on same machine. Am I right?

    thank you



  • I've a similary problem. If i enable traffic shapper, squid won't work. It worked on a older pfsense version, that's why i'm surprised about that. I Would like to know if i did a mistake or if that s just not possible.



  • @casper001:

    Hellow everyone,

    traffic shaping with squid and squidguard not working on same machine. Am I right?

    Could I ask where you found this? I am fighting with my box for the a-zillionth time currently, and maybe your remark might give a clue as to what is wrong with it.

    Thank you  ;D



  • I have read that traffic shaper with proxy on same machine does not work. I am tired of fighting with y pfsense machine :D



  • casper001, Limiter and Squid Proxy still doesn't work?  That's disappointing.  How many release now since 2.1.5?



  • yes my friend i configured squid + squidguard and when enable traffic shaper i cound not access anything at all. I am sorry it's may be my mistake but I have read on forum that they can't work on same machine.



  • @casper001:

    yes my friend i configured squid + squidguard and when enable traffic shaper i cound not access anything at all. I am sorry it's may be my mistake but I have read on forum that they can't work on same machine.

    Same issue with mine…  As soon as shaper enabled, all connectivity is lost. Even from the localhost of the pfsense box. I am running 2.2.4

    In-fact after completing the shaper wizard, I go to check the status-queues and nothing is listed.... But when I go to the firewall-traffic shaper they are all listed... Not sure whats going on or why this isnt working. So for now I troll the board and have my shaper disabled. Would love to get it going soon thou!