I'm pulling my hair out!!!



  • OK… FTP... I've searched and searched and I'm ten times more confused now on what the CORRECT settings are supposed to be to get it to work!?!

    Yes, I've read through: http://devwiki.pfsense.org/FTPTroubleShooting and http://forum.pfsense.org/index.php/topic,7096.0.html AND a mess of other posts... nothing has yet worked!

    I have a public VIP that's PARP, that's not the public router IP.
    I've tried enabling/disabling in every possible combination the FTP Helper on both interfaces.
    and I made sure to create the NAT and Rules AFTER enable/disable FTP Helper.
    I've port forwarded 21 only.

    I can FTP out (LAN -> Internet) ok from the begining...BUT I have yet to be able to FTP in (internet -> LAN)

    The FTP server is CentOS running VSFTPd.

    Can someone help me? Let me EXACTLY what is needed to get FTP in to work????

    I need some majic!

    Thanks!



  • Use CARP type IP's for virtual ip's, not proxy arp.



  • I changed the VIP to CARP….but it still doesn't work....any other settings I need...?

    Do ALL the VIPs have to be changed over to CARP? Or can just the FTP IP be on CARP?



  • @NoDoze:

    I changed the VIP to CARP….but it still doesn't work....any other settings I need...?

    Do ALL the VIPs have to be changed over to CARP? Or can just the FTP IP be on CARP?

    Just the IP using FTP.



  • Hmmm….made no difference....



  • AFAIK, you only need a CARP VIP if you are running the FTP helper on the WAN interface.
    I've had good results running with the helper disabled, restricting the PASV ports on the FTP server, and forwarding the PASV ports. With vsftpd, you need to add pasv_min_port and pasv_max_port options to your config file.



  • WOOOOOOHOOOOOOO!!!!!!!!!!!!!!!!!!!!!!!

    WORKED LIKE A DREAM!!!
    WORKS GREAT!

    THANK YOU!


Locked