Alix 2D + pfSense 2.2.3 boot issue



  • I am helping troubleshoot an issue for a colleague regarding a boot issue on an Alix 2D running the newest version of pfSense. At first glance, this almost seems like a baud rate error ie almost like the baud rate is changing after the initial boot. I dont have hands on yet with the hardware, just the info you see here and the following link to a quick YouTube video. (I hate to add this video as it probably wont be persistent. Sorry future forum viewers).

    Youtube Video

    pfSense Version: pfSense-2.2.3
    Alix Version: PC Engines Alix 2D
    Alix Manufacture Date:2008
    CF Card: SanDisk Ultra CF 4GB card
    Image used: pfSense-2.2.3-RELEASE-4g-i386-nanobsd.img.gz
    Image Other: also tried 2.1 and 2.1.1
    Current Baud Rate: Used default baud of 9600 (Changed in BIOS from the

    Process used to image CF card:
    Followed procedure at https://sgoodger.wordpress.com/2011/03/20/installing-pfsense-on-a-compact-flash-card/
    Tried using physdiskwrite and Win32 Disk Imager
    Disk image write appeared to load without issue onto CF card
    Tried with different Alix board and CF card.
    When pfSense tries to boot, get giberish after process starts

    Hopefully someone has seen this issue before and can quickly pin point the root cause. If not, I'm sure we can identify it soon with some collaborative troubleshooting.

    Thanks everyone!
    ~Andrew



  • –-UPDATE---

    Tested to see if somehow the baud rate was changing during boot ie starts off as 9600, then changes to 115200. We didn't really expect that to be the problem, just wanted to eliminate some variables.

    Also tested older version of pfSense. He loaded the 2.1 image and it worked. He then went back and tried 2.2.3 and got the same gibberish again.

    So it appears to be an issue with the newest version or image of pfSense on this Alix hardware. Perhaps we need a different image, or perhaps it is no longer compatible on this older Alix version?



  • Try 115200 baud in putty (or whatever program you are using for connecting to the console).
    Often the BIOS is 9600 but the speed in the config is 115200. So the first bit of BIOS output and choosing the boot slice comes out at 9600 baud then the real FreeBSD boot output comes at 115200.

    physdiskwrite works fine, I use it all the time. I expect the card and system are fine.



  • Phil is exactly right. You need to set putty at 115200, as this is the new default serial speed on 2.2.x
    You can change the BIOS to match, or get it booted and change the serial from system, advanced.



  • See, that was my first assumption, however, if you look at the update I posted above, I had him test by booting the Alix and opening console using putty at the default 9600, and then when the output started going all crazy, I asked him to close putty, reopen, and try again this time with 115200 to see if the console output returns to normal using the higher baud rate. He tested this and said there was no change. "I tried the baud rate change but it didn't have any effect. ~Joseph"

    I will ask him to give it one more try, but this time will get him to set the bios back to 115200 permanently.

    What I don't understand is how/why the OS is changing this setting which is normally controlled via the BIOS. Why does the new version of pfSense change this to 115200. Do you have some official pfSense documentation verifying this?

    Thanks,
    Andrew



  • –- Update ---

    https://doc.pfsense.org/index.php/Connecting_to_the_Serial_Console

    Here we go… Under "Terminal Settings", it states "The default serial console settings in pfSense 2.2 are 115200/8/N/1"

    "Previous releases of pfSense defaulted to a console speed of 9600 but otherwise had the same settings. Devices shipped from retailers with pfSense pre-installed, such as from the pfSense Store or Netgate, typically have the console speed set to match the BIOS. For example, on an ALIX unit, the console speed would be 38400."

    and finally... The bug update: https://redmine.pfsense.org/issues/3715

    I'm now convinced of my original assumption.

    I will have him make the changes in the BIOS and test again. Hopefully this should resolve the issue.

    Thanks,
    Andrew



  • Joseph, to update the default baud rate stored in the BIOS follow the steps on page 10 of this doc:

    http://www.pcengines.ch/pdf/alix2.pdf



  • I just tried throwing a fresh 2.2.3 nano (2g) cf in an alix that was formerly running 2.1.x
    Make sure you start putty at 115200, then power on the alix. You won't see anything until pfSense starts loading, but it comes up to the assign interfaces just fine.



  • To prevent to get the gibberish output in the Putty, Kitty or terminal program you are using, you must setting all
    three things to the 115200 baud!

    • Putty must be at 115200 baud
    • Alix Board is at 9600 default, so be changed to 115200 baud
    • And then pfSense comes also with 115200 baud as default so
      you will be able to get even a right clear output.

    And as I could assume this would not be the last try out to connect
    over the console to the Alix Board or pfSense so it makes really sense
    to me that this would be changed one times and holds for ever.


Log in to reply