Pfsense 2.2.3 installation on ibase fwa 6504



  • Good morning,

    I would like to install pfsense 2.2.3 on an ibase fwa 6504 appliance http://www.ibase.com.tw/english/ProductDetail/NetworkAppliance/FWA6504.

    I found this similar topic https://forum.pfsense.org/index.php?topic=34799.0 so I decided to install the USB memstick version on the HDD, using a surrogate computer (because I have no flash card and no DB15 vga link.
    Once installation finished, I put the HDD into the appliance, connect a laptop using serial port and Putty (COM1 115200 speed), and start the appliance.
    It boots correctly, then this message appears :

    CPU doesn't support long mode
    

    After searching on web, it seems that this message comes from a 64bits install on a CPU that supports only 32 bits.
    However my CPU is a 64 bits CPU.
    To be sure I installed a 32 bits version but it's less conclusive (I can't boot the appliance).

    After the error message, I acces to a CLI. I can use "?" and "help index" commands to have a list of commands that I can run.
    But there's no one that displays something after running (except reboot command) and I don't have access to the usual menu where we can configure interfaces, IPs etc…

    So that's why I'm looking for help to install pfSense on this type of appliance.

    Thanks !


  • Banned

    @Arkenys:

    However my CPU is a 64 bits CPU.

    The CPU, maybe. The BIOS clearly is not.



  • Do you mean that the BIOS isn't a compatible 64 bits BIOS ?

    I believed that BIOS have no version.



  • Good morning,

    I venture to raise the subject again.
    Is there anyway to fix my problem ?
    A 32 bits version doesn't run on the appliance (just a black screen in CLI).
    A 64 bits version shows me an interface where I can input some commands, but I can't boot pfsense correctly (CPU doesn't support long mode).
    I tried to boot on my USB stick (this memstick is detected by the OS on the appliance), but it doesn't run.

    Please, I really need your help.

    Regards


  • Banned

    What help exactly you imagine here? amd64 clearly won't work (stop wasting your time) unless you get a fixed BIOS; you posted no information about how it looks with i386 (neither "black screen", nor "doesn't run" is useful for diagnosing anything).



  • I expect more than this, that's all.

    So I will repeat what I said before.
    When I install the i386 on my HDD, then I run PuTTY after connecting a link between a laptop and the appliance (serial, COM1, 115200 for speed).
    The usual PuTTY window opens.
    But I can't say what I have, because I have nothing.
    The appliance runs, but I have nothing on my CLI. I can't enter the BIOS or make something as usual.
    However, with the amd64 img, I access to several commands. I access to an OS, but when I use "boot" command, it says "CPU doesn't support long mode".
    If you think that I should install the i386 img, please telle me why my CLI stay black when I run it…

    This is the help that I'm looking for.

    Regards


  • Banned

    Well I frankly think you should get a compatible HW and move. Something that allegedly has a 64bit capable CPU but uses a MB with BIOS that either intentionally or inadvertently screws that feature is not exactly something I'd be keen on using.

    Now, get some console working. VGA header pinout here.



  • According to the spec, it has a CF card slot.

    Why not try the NanoBSD image with it? That doesn't require any install, it would boot straingh into the running state from the CF card, and you might very well have a chance to have it full up and running without even seeing anything on the console.



  • Well, thank you for your help doktornotor and robi.
    I'll try to apply your solutions again.

    Robi, my boss wanted to install pfsense on a HDD (we already have 2 appliances with pfsense installed on a HDD and these appliances run). But these appliances are different than the new device.
    That's why I don't use a CF card for the moment.
    If it's the only way to configure it correctly, I'll try it.

    Thanks again