Squid pára as 00h00



  • Bom dia prezados,

    Estou usando a seguinte configuração:
    2.2.3-RELEASE (amd64)
    Lightsquid         2.41
    squid         2.7.9 pkg v.4.3.6
    squid3         0.2.8
    squidGuard        1.9.14

    Todos os dias pela manhã percebo que o squid e o squidguard encontram-se com o status parado e tenho que subir os serviços manualmente.

    Vendo os logs, encontrei isso de estranho:

    22.07.2015 00:00:06 squidGuard stopped (1437534006.442)
    22.07.2015 00:00:06 squidGuard stopped (1437534006.442)
    22.07.2015 00:00:06 squidGuard stopped (1437534006.441)
    22.07.2015 00:00:06 squidGuard stopped (1437534006.441)



  • Dois Squid instalados?



  • Removi o pacote "squid 2.7.9 pkg v.4.3.6" e reinstalei o "squid3 0.2.8" agora o proxy não funciona mais.

    ERRO

    A URL requisitada não pôde ser recuperada

    O seguinte erro foi encontrado ao tentar recuperar a URL: http://www.globo.com/

    Conexão para 127.0.0.1 falhou.

    O sistema retornou: (60) Operation timed out

    O host ou rede remota pode estar fora do ar. Por favor, faça a requisição novamente.



  • Tem que salvar as configurações e reinicia o serviço e confere se na aba ACL a sua rede está permitida.



  • Em Proxy server > ACLs > Allowed subnets estava em branco, coloquei 192.168.1.0/24, continua não carregando.

    ERRO

    A URL requisitada não pôde ser recuperada

    O seguinte erro foi encontrado ao tentar recuperar a URL: http://terra.com.br/

    Impossível encaminhar esta requisição nesse momento.

    Esta requisição não pode ser repassada para o servidor de origem ou para qualquer cache pai.

    Alguns dos possíveis problemas são:

    Uma conexão à Internet necessária para acessar estes servidores de origem de domínios parece estar fora.
    Todos os caches-pais configurados parecem estar fora de alcance no momento.
    O administrador pode não ter permitido que este cache fizesse conexoes diretas a servidores de origem.



  • Estou com o mesmo problema, todos os dias o squid para exatamente as 0.00 horas.

    só não entendi o motivo do erro.

    Aug 12 00:00:18 kernel: pid 6673 (squid), uid 62: exited on signal 11
    Aug 12 00:00:20 Squid_Alarm[39785]: Squid has exited. Reconfiguring filter.
    Aug 12 00:00:20 Squid_Alarm[41146]: Attempting restart…
    Aug 12 00:00:22 php: swapstate_check.php: The command '/usr/pbi/squid-i386/sbin/squid -k kill -f /usr/pbi/squid-i386/local/etc/squid/squid.conf' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Aug 12 00:00:23 squid[67202]: Squid Parent: will start 1 kids



  • Já descobri o que ocasionava o erro em meu squid.

    Devido a uma falha de digitação, na aba Local Cache o "Maximum object size" estava setado com um valor de 400000 kilobytes, 10 vezes mais que o valor recomendando, ajustei para 40000 e acabou o problema.



  • Senhores bom dia!

    esse problema eu já peguei diversas vezes e resolvi executando os comandos abaixo para limpeza do cache.

    Executem os comandos abaixo via command:

    /usr/local/etc/rc.d/squid.sh stop

    rm -rf /var/squid/cache/

    mkdir -p /var/squid/cache/

    chown proxy:proxy /var/squid/cache/

    chmod 750 /var/squid/cache/
    squid -z

    /usr/local/etc/rc.d/squid.sh start



  • Normalmente está relacionado a algum valor ou informação errada nos campos de configuração. Sempre é bom revisar um a um a ir validando.