Sites that don't like Dual Wan



  • Currently I have a dual WAN (ADSL2+) on an Intel Atom D2550 1.86Ghz running pfsense 2.2.3, however, certain websites don’t work under dual wan settings (i.e Banking sites) is there any way to get around this problem besides turning on and off a WAN each time I need to access these sites?



  • What I have done is creating two routing groups, 1 called failover, and 1 called load_balancing

    In load balancing, all internet connections are Tier_1 (Trigger level, High Latency)

    In Fail Over the fastest connection is Tier_1, the second fastest is Tier_2 and so on (Trigger Level is Member Down)

    Than I created an ALIAS (called no_load_balancing) with all the sites hating the connection jumps

    Finally in Firewall rules just before your lan to any rule, insert a new rule as follows :-

    Action = Pass

    Interface = Lan

    Destination : Type Single host or alias, and add No_Load_Balancing (or whatever you called your alias)

    In advanced features, choose the Failover group as your gateway.

    I do not know if  this is the best way to do it, or if there is a simpler way, but it works for us

    J



  • Thanks Jackall I give it a try.



  • I've noticed enabling sticky connections (System > Advanced > Miscellaneous) fixes a lot of websites that don't like the IP moving around on them, like banks.  In general, I just toggle it on when I need that site, and off when I'm done, as sticky connections also slows down sites that properly handle multi-wan, forcing them onto a single link.



  • @jackall:

    In load balancing, all internet connections are Tier_1 (Trigger level, High Latency)

    In Fail Over the fastest connection is Tier_1, the second fastest is Tier_2 and so on (Trigger Level is Member Down)

    Than I created an ALIAS (called no_load_balancing) with all the sites hating the connection jumps

    Finally in Firewall rules just before your lan to any rule, insert a new rule as follows :-

    Action = Pass

    Interface = Lan

    Destination : Type Single host or alias, and add No_Load_Balancing (or whatever you called your alias)

    In advanced features, choose the Failover group as your gateway.

    I do not know if  this is the best way to do it, or if there is a simpler way, but it works for us

    J

    can you send screenshots of this settings please