NAT for VOIP phone



  • I had a small problem with the NAT with my VOIP line. It establishes an outbound connection on port 5060 (standard SIP) to the SIP server. The SIP server sometimes communicates to it of course as well. The communcation from the SIP server was getting blocked by the firewall. Creating a NAT rule solved the problem but there really should be no need for the NAT rule. Is there any way to resolve this?



  • SIP behind a NAT without portforwards only works if your SIP provider has a STUN server that helps to transverse the NAT. Search the forums for SIP related topics, there are already some solutions for this problem if you don't have a STUN server.



  • @nsumner:

    I had a small problem…

    You may use sip-proxy in packages, without forwarding any ports.
    Or, use IAX2-protocol.



  • I can't use a STUN server. A STUN server doesn't solve the problem and according to FWD a STUN server can not be used for a syymetrical NAT. They however suggest using a Outgoing Proxy. I will see if my Service provider has an outgoing proxy avaliable.



  • I use a SIP here, I haven't configured a STUN server in the SIP, nor have I setup any port forwarding.  I pretty much just plugged it in and configured the sip.domain.com registration address with my user/pass and it just worked.



  • Then you have a good provider that is using a proxy at their end which will rewrite the sipmessages with what they see the packets coming from.


  • LAYER 8 Moderator

    As it may cover the topic, I had problems with my old router and VoIP (United Internet), too. Problem was outgoing conections on random ports. But with pfSense and static port option in NAT, the problem disappeard automagically. The only thing you need is the one NAT rule mentioned and thats it. No Problems here anymore. Without any other software as e.g. the already mentioned proxies, you'll have to use a NAT rule.

    Grey


Log in to reply