[solved] pfSense 2.2.3 gets stuck in boot loop / doesn't boot



  • Hi all, this is my first time attempting to install x86 pfSense on a pc. I have a decent amount of experience with linux and am comfortable with basic networking however I've been unable to get pfSense to boot properly after installation.

    I've had a look around this forum for people with similar issues and tried solutions such as in the thread: https://forum.pfsense.org/index.php?topic=45572.0 but nothing has worked!

    My Hardware:
    I'm trying to install pfSense on an old Dell Dimension 8400 with an Intel Pentium 4 processor, on the included SATA drive. I also have a spare IDE drive lying around but I'd rather use it for something other than a pfSense install (seems like a waste of 1.5TB).

    I am using the integrated NIC on the Dell Dimension 8400, and a TP-Link TF-3468 NIC which both seem to work fine from the liveCD.

    My hardware is not x64 capable.

    My issue:

    I get the screen where you need to press F1 to boot pfSense, as soon as I press F1 the machine restarts. I have tried booting pfSense from GAG and the machine restarts instantly, I don't see any error message or any spinner first. If I don't press anything, after a small amount of time the machine restarts (I assume this is when pfSense would normally automatically boot.)

    What I've tried:

    • Various root drive configurations, with the main partition pfSense is being installed to being <32gb, <4gb but I always get the same result.

    • Unchecking the 'packet mode' box during bootblock installation but the menu seems a bit bugged for me - I can't select the box next to the disk I am using, only the box of a 2nd blank listing below (I can get a photo of this if anyone would like to see).

    • To boot with the freeBSD liveCD to format the disk with that instead (assuming this is a disk issue) however it didn't like my usb keyboard and I didn't want to go through the trouble of getting it working.

    Has anyone experienced similar problems or have any ideas on how to resolve this? Its driving me crazy! I'm keen to replace my cheapo router provided by my ISP with pfSense as it can no longer handle the amount of devices connected to it reliably.

    Thanks in advance!



  • Its driving me crazy! I'm keen to replace my cheapo router provided by my ISP with pfSense as it can no longer handle the amount of devices connected to it reliably.

    Try out please the NanoBSD on an USB Stick! It is really fast to deploy and keep your pfSense firewall running!
    And then please let us talk about hardware, pfSense is running on many various different systems, but also not
    on all!

    Perhaps you really should be buying a small device that is capable to hold pfSense and keep
    it also running smooth and liquid? Only perhaps I mean.



  • Thanks for your reply BlueKobold! It seems it was a disk error all along, I managed to dig out an old 12GB IDE drive that was still in good condition, updated the bios to the latest version and tried a reinstall and everything worked great! I tried installing again to the other disk but it still rebooted when I tried to boot.

    Strange that the 160gb SATA drive didn't work because it seemed to be working fine with other operating systems, but I'm sure it'll come in handy when I'm doing another build.



  • May also have been an issue with the SATA controller being in AHCI and/or Compatibility mode.

    Look for a Bios setting for the SATA controller that you might change.

    There's a note in: https://doc.pfsense.org/index.php/Boot_Troubleshooting about some Dell USB settings that may apply as well (that's a good general guide BTW).

    I've installed on a few Dell boxes and vaguely recall having to do a few weird things with Bios and/or SATA port choices to get them to boot.

    Just to complicate matters the disk drivers in FreeBSD changed along with pfSense 2.2+ so that's makes things more interesting on older hardware.



  • divsys, when I was still having the problem I had a look at that guide and made sure the drive was set to AHCI - is it meant to be set to something else? I had it set that way because of the suggestion in the "BIOS/Disk Errors" section.

    I couldn't find any usb settings in the bios, even after I updated it to the latest version. I read in a lot of places to look for "legacy usb compatibility" settings, seems like the system might be so legacy that "legacy usb" might refer to its regular usb capabilities  :o



  • Normally AHCI is the way to go, but I've seen scenarios where you simply have to "change to the other mode" when things don't boot.
    Seeing as the IDE seems to be recognized properly, setting the SATA to Compatibility (so it looks like an IDE) may be what you need.

    Might also be worth a look to see if there's a Bios update available.



  • @nfw I recently bought new hardware (64bit) and when attempted to install pfsense on it i had EXACTLY the same issues you did (bootloop). I tried to troubleshoot it the same way you did but no luck.
    NanoBSD on a CF card would boot fine but had other issues like not being able to run snort or suricata  and…!

    Frustrated and a little sad for my misfortune i decided to use it as an extra GNU/Linux-desktop for experimenting. It served well that purpose until this noon when i decided to give the 2.2.4 a go!

    BINGO!!! installed just fine and is now my new pfs-box!

    I did Uncheck the 'packet mode' box during bootblock installation but i don't know if that was necessary. I didn't bother reinstalling just to check it.

    SATA SSD 60gb full partition from Muskin.

    I am planning to make a new thread about the hardware i used. Very... VERY... Happy with the result

    Regards!