Warning on upgrade from 2.2.4 dev to 2.2.4 release



  • Below line appears on alix, nanobsd in serial console

    Warning: Invalid argument supplied for foreach() in /etc/inc/upgrade_config.inc on line 3610



  • Just means you don't have any IPsec config when it's doing the config upgrade. I added a check to skip that part where you don't have IPsec configured, to prevent the noise in that case in future releases. Doesn't hurt anything.