Bagaimana cara install squid 3.5 di 2.2.3



  • mugnkin ada agan-agan yg sukses migrasi dari squid 3.4 ke 3.5 mohon bimbingannya



  • karena pfsense 2.2.4 masih menggunakan squid 3.4



  • sundul  ;D



  • untuk update squid butuh 2 file
    1. squid 3.5.3 download disini
        https://files.pfsense.org/packages/10/All/
    2. squid.inc
        kenapa squid.inc harus didownload ? karena squid.inc bawaan hanya support squid 3.4.1. squid.inc bawaan ada fitur yg tidak support untuk squid 3.5. mungkin agan2 ato master2 pnya file squid.inc yg support 3.5 boleh dibagi.



  • @shr_kaza:

    untuk update squid butuh 2 file
    1. squid 3.5.3 download disini
        https://files.pfsense.org/packages/10/All/
    2. squid.inc
        kenapa squid.inc harus didownload ? karena squid.inc bawaan hanya support squid 3.4.1. squid.inc bawaan ada fitur yg tidak support untuk squid 3.5. mungkin agan2 ato master2 pnya file squid.inc yg support 3.5 boleh dibagi.

    Bisa disebutkan kendala dan pengaruhnya bro, jika squid.inc tidak sesuai?



  • sudah ane bales disini >> https://forum.pfsense.org/index.php?topic=100492.msg561906#msg561906
    tapi risiko ditanggung penumpang lho ya



  • @kentuss:

    sudah ane bales disini >> https://forum.pfsense.org/index.php?topic=100492.msg561906#msg561906
    tapi risiko ditanggung penumpang lho ya

    saya sdah pernah melakukan seperti yg anda posting, semua file .inc yg dibutuhkan harus didownload. tnpa file tersebut, squid tidak jalan



  • @landylandy:

    kalau cara saya menginstal squid 3.5.3 begini gan:
    1. instal dulu squid 3.4.10 dari package
    2. buat CA certificate
    3. sebelum mengutak-atik squid 3.4.10 yg sudah terinstal tadi, kita download dulu squid 3.5.3 dengan cara ketik di putty:
    fetch https://files.pfsense.org/packages/10/All/squid-3.5.3-i386.pbi
    4. setelah itu instal dengan masih menggunakan putty:
    pbi_add –no-checksig -f squid-3.5.3-i386.pbi
    5. lalu jalankan:
    rm -rf /usr/pbi/squid-i386/etc
    ln -s /usr/pbi/squid-i386/local/etc .
    ln -s /usr/pbi/squid-i386/local/lib .
    ln -s /usr/pbi/squid-i386/local/libexec .
    ln -s /usr/pbi/squid-i386/local/share .
    ln -s /usr/pbi/squid-i386/bin sbin
    6. reboot mesin pfsense-nya
    7. coba jalankan squid -v pastikan versi sudah 3.5.3
    8. kalau sudah terinstal dgn sempurna barulah web gui pengaturan squid kita aktifkan ;)
    9. CMIIW (oh iya, pfsense yg saya gunakan masih versi 2.2 release)

    saya sudah coba, tapi versi 2.2.6 amd, semua sukses pada waktu install. versi sudah 3.5.3. tapi lewat gui, squid error ( stop ). letak error dimana ?



  • @landylandy:

    itulah gan, errornya mungkin karena masih ada bug-nya makanya pihak developer masih belum menyertakannya dalam package dan masih menggunakan squid versi 3.4.10.
    squid versi 3.5.3 ini idealnya secara pengalaman saya, instalnya bagus kalau di awal instalan dalam artian belum menginstal package lain karena belum bisa sinkron dengan banyak package sehingga biasanya error. jadi pake sistem trial and error :), instal dia dulu sebelum instal package yg lain biar ketahuan kalau tidak compatible :).
    secara pengamatan saya ya gan, versi ini lebih lebih agresif menangkap cache dan hit lebih banyak walau refresh_pattern belum ditambah alias masih default dibanding versi 3.4.10 :). CMIIW

    harus fresh install ?



  • Udah cb OpnSense blum? varian freebsd jg, squid nya sdh 3.5



  • @kentuss:

    Udah cb OpnSense blum? varian freebsd jg, squid nya sdh 3.5

    bang kentuss sdah pke opnsense ? bagi2 dong cara settingnya



  • @shr_kaza:

    @kentuss:

    Udah cb OpnSense blum? varian freebsd jg, squid nya sdh 3.5

    bang kentuss sdah pke opnsense ? bagi2 dong cara settingnya

    sama kok caranya ama pf, cmn guinya blum support ssl..kudu manual… ;D
    masih lebih handal pf & smoothwall


Log in to reply