Fw1 causes fw2 to reboot when syncing



  • I have two firewalls, fw1 (2.2.2) and fw2 (2.2.2 & 2.2.4).  Whenever I enabled ha sync on fw1, fw2 does a dump and then is stuck in a reboot loop (I've submitted the crash report).  First I thought there was a hardware/software issue on fw2, so I re-installed 2.2.4, but the issue continued, so then I did a fresh install of 2.2.4, but the issue remained.  Then thinking the difference in versions could be adding to the issue, I did a fresh install of both fw1 and fw2 (and used individual backup files (not the full config) and only restored aliases, firewall rules, etc….everything else I configured manually.

    Everything was working great, for a couple hours until I realized I forget to restore/add my traffic limiters, so I started to manually add the limiters...I had only added a couple and applied it to a rule, and the same thing happened, received a dump screen, then went into an endless reboot loop.

    Anyone else see this, or did I find a bug in the limiters?  (I've submitted a number of crash reports)

    Thanks,



  • Also, I've replaced the hardware on both fw1 and fw2 thinking there may have been hw issues, but to no avail, I get the same results on completely different hardware.


  • Netgate

    Yeah.  Limiters are completely broken on 2.2.  pfSync crashes, adding NAT or proxies disables limiters, etc.

    Unfortunately, it looks like they've punted the fix to 2.3.  I'm still on 2.1.5 where limiters are required.

    I believe the pfSync bug is here:

    https://redmine.pfsense.org/issues/4310



  • Ok, thanks.  So what's the work around, either 1) don't use limiters when using HA, or 2) don't use HA when using limiters?


  • Netgate

    Don't use 2.2 if you require limiters.



  • Ok, thanks.



  • Limiters are not completely broken on 2.2.x, but there are caveats on interfaces where NAT is applied (usually just WANs) they'll break traffic, and in combination with pfsync they'll crash or hang the secondary. Some of the related issues have been at least improved some, but it's a difficult underlying OS issue.



  • I'm not using NAT and have it completely disabled, but yet this reboot issue persist.



  • This issue is separate from the NAT one. For that case you'd have to disable pfsync to stop that.