Routing Linux machines to Azure through VPN



  • Good afternoon,
    Having an issue whose solution is evading me.

    Our local network is on a 255.192.0.0 subnet mask with the rest of the address space in our Azure VPN.
    Our windows machines navigate to cloud VMs fine, but our Linux machines cannot.
    In trying to diagnose, I'm getting a message from a ping "Redirect Host" and then 1 successful ping, with the rest going "Destination Host Unreachable".

    In searching for the solution, I ran into this: " the router to which it was sent thinks it isn't the right router, and thinks that some other router provides a better route to that particular host, so it's saying "pick another route" ("redirect") "for packets to that particular host ("for host"), and provides the IP address of the router to which the packet should have been sent in order to get it to the host in question."

    In this case, my pfSense box is the router/gateway and is working correctly to route Windows traffic.

    Any suggestions on a fix?
    Thank you kindly,
    PB



  • Found the answer here: https://www.raspberrypi.org/forums/viewtopic.php?t=83119&p=589426

    "I figured out the issue. Its related to a "bug" within pfsense (or maybe freeBSD). In order for the firewall its self to use services from the other end of a vpn tunnel you need to put a static route into its routing table I had a static route in it for 10.1.2.0/24 gateway 192.168.131.254 on the lan interface. I had this route in there because I was testing ldap auth and also for snmp on the internal interface from the other end of the tunnel. Once I disabled this route, I was able to ping to the other end without the redirect."

    I added a static route and now the Linux machines are happy.