WAN not taking DHCP from cable modem



  • Hello all,

    PfSense 2.2.2
    Virtualized

    I have been having this problem where the WAN port does not take an IP from the cable modem. I have been having this issue and end up rebuilding the pfsense. I don't want to do that again.

    After a reboot, the system hangs on configuring the WAN ( i assume cause it can't get the IP). I think see an error relating DHCP and /etc/…. being full.

    I tried to reboot from the GUI but get a 503 error. I tried removing bandwidthd but that gives me a 500 error.  I am not sure what do do at this point.  I tried restarting the php-fpm but it get the error "Cannot open pidfile 'var/run/php-fpm.pid': No such file or directory.

    I do not know what else to try other than rebuilding.  Any suggestions on how to fix and or keep it from happening again?



  • Upgrade to 2.2.4. Looks like you're losing power and ending up with corrupt group and/or passwd files, which is fixed in 2.2.3 and better in 2.2.4.