Locked out of webConfigurator



  • I am not exactly sure what I did to bork my system but I was playing with certificates, trying to create a certificate so I don't get the untrusted garbage from a self-signed certificate. I believe the last thing I did was change which certificate the webConfigurator would use for logging in when I lost the ability to reach webConfigurator. pfSense is still doing its job, I still have internet access through it, I have just lost the ability to control it via the webConfigurator. I had SSH enabled and I can SSH into the machine. I tried using option "11) Restart webConfigurator" but that didn't help. I rebooted and that didn't help. I used nmap to look for open ports to my machine and it is only reporting ports 22, 53 and 2189 as open. I'd think that port 443 should be open… which is probably my problem but I don't know how to rectify that.



  • Reset IP on LAN from console and revert webconfig to http.


  • Banned

    Noone reads the docs? Sigh.

    https://doc.pfsense.org/index.php/Locked_out_of_the_WebGUI

    Choose to reset the LAN IP, enter the same IP, and it will prompt to reset the WebGUI back to HTTP.



  • I read through that page over and over again. I guess the frustration of borking the system prevented me seeing that sentence. I guess I thought I could do it logged in via SSH but that didn't work. I went and put a monitor back on the machine and did it locally and it worked. Also, being that it is now 2AM when I'm normally asleep at this time may have something to do with the oversight. It is back and working properly again now.