Shell command 'pkg' does not contain any packages



  • Hello guys,

    My first ever post on the pfSense forums. Such fun!

    I am using pfSense 2.2.4-RELEASE (amd64) FreeBSD 10.1-RELEASE-p15 on a pfSense SG-2440 (https://www.pfsense.org/products/product-family.html#sg-2440)

    I am attempting to install a FreeBSD package via the shell command 'pkg' (as described in https://doc.pfsense.org/index.php/Installing_FreeBSD_Packages), but the repository seems to be completely empty.

    root: pkg update
    Updating FreeBSD repository catalogue...
    FreeBSD repository is up-to-date.
    All repositories are up-to-date.
    
    more /etc/pkg/FreeBSD.conf
    # $FreeBSD$
    #
    # To disable this repository, instead of modifying or removing this file,
    # create a /usr/local/etc/pkg/repos/FreeBSD.conf file:
    #
    #   mkdir -p /usr/local/etc/pkg/repos
    #   echo "FreeBSD: { enabled: no }" > /usr/local/etc/pkg/repos/FreeBSD.conf
    #
    
    FreeBSD: {
      url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/share/keys/pkg",
      enabled: yes
    }
    

    Nothing in my /usr/local/etc/pkg/repos/FreeBSD.conf.

    But no matter what I search for, or try and install… nothing.

    /root: pkg search vi
    /root:
    
    

    Any idea what I am doing wrong?

    Kind regards,
    Mark.



  • …and I worked it out myself. The action of creating my post here made me look at things afresh.

    The ${ABI} variable isn't set on my system.

    I edited the FreeBSD.conf file so that url read:

    url: "pkg+http://pkg.FreeBSD.org/freebsd:10:x86:64/latest",
    

    And now it works.

    Thanks,
    Mark.