Squid and "Do not cache" option



  • Running 1.2 RELEASE and squid package 2.6.18.1

    Using the do not cache option, IP addresses do not seem to work.  If I enter a host name, then I get TCP_HIT_MISS for each request to that host.

    Is this a known issue?  We do not want to cache any requests to our internal webserver for development reasons.

    Thanks



  • Try the "Do NOT proxy Private Address Space (RFC 1918)" option.



  • @mhab12:

    Try the "Do NOT proxy Private Address Space (RFC 1918)" option.

    Its in the DMZ, so its not a private address.



  • Sounds like you're more interested in 'do not proxy' as opposed to 'do not cache'.  Search this forum for bypassing the squid proxy.  It has been discussed at length and resolved, as older versions of squid had issues with slow/certain sites and other users had to bypass them.  It involves editing some files manually, but shouldn't be too bad.



  • @mhab12:

    Sounds like you're more interested in 'do not proxy' as opposed to 'do not cache'.  Search this forum for bypassing the squid proxy.  It has been discussed at length and resolved, as older versions of squid had issues with slow/certain sites and other users had to bypass them.  It involves editing some files manually, but shouldn't be too bad.

    Yeah, a bypass would be fine as well.  I found the post you mentioned, but it does not seem to work.

    http://forum.pfsense.org/index.php/topic,6169.0.html

    The do not cache should work as well.  Any more ideas out there?



  • Any more ideas out there?

    We are looking for a way for all clients to not proxy or not cache requests to a set of IP addresses that are not in the private space.

    Thanks!



  • Any updates/ideas?  It would be nice if the Do not cache option would work with IP addresses.  Thanks!



  • In squid < 3.0, you want the no_cache directive.

    Usage  no_cache deny|allow aclname

    Description
    A list of ACL elements, which, if matched, cause the reply to be immediately, removed from the cache. In other words, use this to force certain objects to never be cached.

    Default
    acl QUERY urlpath_regex cgi-bin ?
    no_cache deny QUERY

    The word 'DENY' is to indicate the ACL names, which should NOT be cached

    Example
    acl DENYPAGE urlpath_regex Servlet
    no_cache deny DENYPAGE
    The DENYPAGE acl assures that the url containing Servlet will NOT be cached.


Log in to reply