Slower than expected Download Speed (Changing speed/duplex doesn't help)



  • Comcast recently boosted download speeds to 75Mbps. Problem is I'm only getting around 44Mbps with pfsense 2.2.3 and 2.2.4. I've tried the usual things including changing the speed/duplex settings on the WAN interface, MTU. Even tried a clean install with no rules other than the default and still don't get anything faster than about 44Mbps. I connected my Mac directly to the modem and confirmed I am getting the 75+Mbps speeds. I am running pfsense as a VM in ESXi 5.5. I thought maybe the NIC was bad, but assigned it to a different VM (Windows) and confirmed it gets the 75+Mbps speed also. So, at this point I think the issue is with pfsense,  but not sure what could be the cause if it's not duplex issues, which is what I think usually causes these kind of issues. Both LAN and WAN NICs are gigabit. Have also done the fetch test directly from the pfsense console and get same ~44Mbps speeds.  Any suggestions?

    Thanks in advance.



  • You mentioned nothing about the hardware that you are running your VM on other than the gigabit interfaces.

    I have several older boxes here with multiple gigabit interfaces on a PCI bus.  The bus being the limiting factor.  My Lanner built board with 6 gigabit interfaces on a PCIe bus can easily smoke my other boards.



  • The cards are older PCI cards. I have ESX running on a desktop that I built about 3 years ago with an Asus MB. Didn't think about PCI vs PCIe would have a big impact. Guess it's time to upgrade NICs. Thanks!



  • Anyone with information on Forum