Packages are currently being reinstalled in the background



  • Dear all,

    after upgrade pfsense  to 2.2.4 .its poping an message "packages are currently being reinstalled in the background.Do not make changes in the GUI until this is complete.".

    I don't know why this message is poping,I checked none of the packages are installed in the background.Please guide me how to resolve this.

    Regards,

    Linuxcub.


  • Banned

    @linuxcub:

    I don't know why this message is poping,I checked none of the packages are installed in the background.

    Not really sure wow did you check this? They either ARE still reinstalling or the reinstall failed somewhere and did not clear the lock. It's not a message popping out of the blue…  ::)



  • I am having the same message.  Been going on for three days.



  • A reboot solved my problem.



  • Hi All,

    I have fixed it!!!!

    This error was given lot of frustration to me ,after long research I found the Problem.

    Troubleshooting method:

    Diagnostics -> Backup/Restore -> Reinstall packages:

    Its work like charm.

    Regards,

    linuxcub



  • I had the same issue with the automatic upgrade from 2.2.3 to 2.2.4 - I didn't notice anything in the general system log identifying a package install failure.
    The reinstall packages did not immediately resolve the GUI popup. I rebooted after reinstalling packages, and the popup went away, so I don't know if it was the package reinstall or reboot that actually was required.



  • Same thing for me on a 2.2.3 to 2.2.4 upgrade.
    The upgrade took 6 hours! and now for the Packages are currently being reinstalled in the background, been running for 36 hours.
    I will try the Diagnostics -> Backup/Restore -> Reinstall packages: method above



  • Same here, I noticed a "clear package lock" button in that area:

    Diagnostics -> Backup/Restore -> Reinstall packages

    Then I noticed on the installed packages list that there were several packages that had available updates.  So one of the packages isn't re-installing well.  I just manually updated / reinstalled the packages that had updates in the pkg button.


Log in to reply