Freeradius not starting automaticly when booting up PFSense



  • Freeradius package is not starting automaticly upon startup, but after PFSense is loaded I can start it using Status -> Services.
    Only error I can find in the logs is:

    php-fpm[242]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'

    Seems that a stop command is issued instead of a start…

    How to debug?

    Regards,
    Donald.



  • Shellcmd: Settings –->add -> service radiusd.sh restart -> (shellcmd)



  • Do you ment ssh'ing into pfsense, I do have ssh shell and pfSense Developer Shell there, but can't find anything to add something, or do you ment via webconfigurator?


  • Banned

    Install Shellcmd package. From GUI. Use it. Done. Plus, regarding the message, no, it's using restart_service(), so - when it's not running, stop fails. Completely harmless log noise.



  • Okay, clear.

    The package FreeRADIUS is not starting at boot, but is giving the error above, when I manually start it, it works.


Log in to reply