TP-Link TL-WN851ND needs frequent disabling and re-enabling


  • Hey all, I've got an Atheros based TP-Link TL-WN851ND that needs frequent disabling and enabling to get my wifi back up. Not a huge deal, but at 2-3 times a day, pretty darn inconvenient.

    Name router
    Version 2.2.4-RELEASE (amd64)
    built on Sat Jul 25 19:57:37 CDT 2015
    FreeBSD 10.1-RELEASE-p15

    Platform pfSense
    CPU Type AMD Opteron™ Processor 246 HE
    2 CPUs: 2 package(s) x 1 core(s)
    Uptime 9 Days 06 Hours 19 Minutes 16 Seconds
    Current date/time
    Wed Aug 19 23:10:58 CDT 2015

    cablenic WAN
    (DHCP) up 1000baseT <full-duplex,master>-- IP omitted --
    cablenic DMZ down none
    192.168.1.1
    cablenic OPT1 down autoselect
    cablenic OPT2 up 1000baseT <full-duplex>cablenic OPT3 up 1000baseT <full-duplex>cablenic OPT4 up 1000baseT <full-duplex>cablenic OPT5 down autoselect
    cablenic OPT6 down autoselect
    cablenic OPT7 down autoselect
    cablenic OPT8 down autoselect
    wlan_d WLAN up autoselect mode 11ng <hostap>cablenic IBRIDGE up
    192.168.2.1

    DMZ is a single port, opt1-8+WLAN are in the bridge ibridge.</hostap></full-duplex></full-duplex></full-duplex></full-duplex,master>


  • Is there a question in there?


  • @rjcrowder:

    Is there a question in there?

    As I stated, I have to disable/enable my wireless card multiple times a day and doing so is annoying. Therefore, the implied question would be, what can I try so I don't need to do this multiple times a day?

  • LAYER 8 Netgate

    Get a real AP.  You know the kind with a radio or two in it and an ethernet port.

    Put it on your LAN and you're done.


  • Not a huge deal, but at 2-3 times a day, pretty darn inconvenient.

    If you get WiFi inside of pfSense working and it is running liquid it is ok, but if you get
    trouble this can be that you are fiddling it out in weeks and nothing changed!
    It mostly depends on more then one point, it can be the same hardware or config
    but one times it runs and one times not! So the best way is to set up a external WiFi
    AP and connect this to a LAN switch.


  • @Derelict:

    Get a real AP.  You know the kind with a radio or two in it and an ethernet port.

    Put it on your LAN and you're done.

    Guaranteed easiest most reliable way to solve your problem…


  • Thanks, all. Those were pretty much the answers I was expecting. Time to browse some ubiquiti hardware.