Cisco PIX disconnect issue.



  • First I would like to say wonderful software guys, great job.

    In my deployment, I have around 15 remote sites all connected with IPSEC vpn tunnels "in a star fashion" the hub being a PfSense box. Two of the clients also use pfsense and are working beautifully. The rest are all Cisco PIX 501's. All but 4 of those work fine.

    I followed the monowall guide in setting up these pix's and pfsense.

    Those 4 pix's connect but will never stay connected. I must disable and renenable the trunk. I have a pingable address in "Automatically ping host", "86400" in lifetime and have tried switching between "2" and "off" on "PFS key group", all with no luck.

    Here is a sample output of my ipsec log.

    May 8 12:17:11 racoon: [BoothEnergy]: ERROR: X.X.X.X give up to get IPsec-SA due to time up to wait.
    May 8 12:17:11 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:17:10 racoon: [VPN to Inez]: INFO: initiate new phase 2 negotiation: X.X.X.X[0]<=>X.X.X.X[0]
    May 8 12:17:10 last message repeated 2 times
    May 8 12:17:06 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:17:04 racoon: [Argus]: INFO: initiate new phase 2 negotiation: X.X.X.X[0]<=>X.X.X.X[0]
    May 8 12:17:03 last message repeated 4 times
    May 8 12:16:56 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:54 racoon: [Marco]: ERROR: 65.82.252.245 give up to get IPsec-SA due to time up to wait.
    May 8 12:16:53 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:51 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:50 racoon: [Argus]: ERROR: X.X.X.X give up to get IPsec-SA due to time up to wait.
    May 8 12:16:48 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:46 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:43 racoon: [VPN to Inez]: ERROR: X.X.X.X give up to get IPsec-SA due to time up to wait.
    May 8 12:16:43 last message repeated 2 times
    May 8 12:16:41 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:41 racoon: [BoothEnergy]: INFO: initiate new phase 2 negotiation: X.X.X.X[0]<=>X.X.X.X[0]
    May 8 12:16:36 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:31 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:29 racoon: [Wright Management]: ERROR: X.X.X.X give up to get IPsec-SA due to time up to wait.
    May 8 12:16:27 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:26 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:26 racoon: [Catletsburg]: INFO: IPsec-SA established: ESP/Tunnel X.X.X.X[0]->X.X.X.X[0] spi=1062033960(0x3f4d5a28)
    May 8 12:16:26 racoon: [Catletsburg]: INFO: IPsec-SA established: ESP/Tunnel X.X.X.X[0]->X.X.X.X[0] spi=123063969(0x755cea1)
    May 8 12:16:26 racoon: WARNING: attribute has been modified.
    May 8 12:16:26 racoon: WARNING: ignore RESPONDER-LIFETIME notification.
    May 8 12:16:26 racoon: [Catletsburg]: INFO: initiate new phase 2 negotiation: X.X.X.X[500]<=>X.X.X.X[500]
    May 8 12:16:26 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:25 racoon: INFO: purging spi=120073764.
    May 8 12:16:25 racoon: [Catletsburg]: INFO: ISAKMP-SA established X.X.X.X[500]-X.X.X.X[500] spi:ff6cf9f0cd73451e:525ad03944c99436
    May 8 12:16:25 racoon: NOTIFY: couldn't find the proper pskey, try to get one by the peer's address.
    May 8 12:16:25 racoon: WARNING: port 62465 expected, but 0
    May 8 12:16:25 racoon: INFO: received Vendor ID: CISCO-UNITY
    May 8 12:16:25 racoon: INFO: received Vendor ID: DPD
    May 8 12:16:25 racoon: INFO: received Vendor ID: draft-ietf-ipsra-isakmp-xauth-06.txt
    May 8 12:16:24 racoon: [Marco]: INFO: initiate new phase 2 negotiation: X.X.X.X[0]<=>65.82.252.245[0]
    May 8 12:16:24 racoon: INFO: begin Aggressive mode.
    May 8 12:16:24 racoon: [Catletsburg]: INFO: initiate new phase 1 negotiation: X.X.X.X[500]<=>X.X.X.X[500]
    May 8 12:16:24 racoon: [Catletsburg]: INFO: IPsec-SA request for X.X.X.X queued due to no phase1 found.
    May 8 12:16:21 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:21 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:20 racoon: [Argus]: INFO: initiate new phase 2 negotiation: X.X.X.X[0]<=>X.X.X.X[0]
    May 8 12:16:16 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:16 racoon: ERROR: not acceptable Identity Protection mode
    May 8 12:16:13 racoon: [Catletsburg]: INFO: ISAKMP-SA deleted X.X.X.X[500]-X.X.X.X[500] spi:7015b2e593734fd4:525ad03955769ff8
    May 8 12:16:13 racoon: [VPN to Inez]: INFO: initiate new phase 2 negotiation: X.X.X.X[0]<=>X.X.X.X[0]
    May 8 12:16:12 racoon: ERROR: phase2 negotiation failed due to phase1 expired. 7015b2e593734fd4:525ad03955769ff8:0000be31
    May 8 12:16:11 last message repeated 2 times
    May 8 12:16:06 racoon: ERROR: not acceptable Identity Protection mode



  • No help at all?



  • Still no replies from anyone but I am still attempting to help myself so here is what I'm doing and here are my results.

    One of the trunks that keeps going down is a cisco PIX. So I remove the 86400 lifetime from SA 2. and kept group on 2 "I also tried off".

    I get the exact same results.

    I will try tonight adding the lifetime back and removing the first lifetime.



  • Hello,

    Racoon really doesn’t want to recieve a FQDN when it’s trying to create a connection with a shared key.
    Make sure the Cisco has the line

    • isakmp identity address in it’s config.

    Don’t forget to set your DH and PFS number at the same number as the Cisco.
    In the past i have had problems between pfsense and "cisco´s" with DPD.

    Regards
    Heiko



  • I already do. Here is the config of one of my PIX's.

    Building configuration…
    : Saved
    :
    PIX Version 6.3(4)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password lAUX2PI8tpE7r9bA encrypted
    passwd lAUX2PI8tpE7r9bA encrypted
    hostname pixcat
    domain-name ANY.COM
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 192.168.145.0 VPN_Client
    name 192.0.1.0 Lexington
    object-group service port-RTP-tcp tcp
      port-object range 10000 20000
    object-group service port-RTP-udp udp
      port-object range 10000 20000
    object-group service port-SIP-tcp tcp
      port-object range 5004 5082
    object-group service port-SIP-udp udp
      port-object range 5004 5082
    access-list outside_access_in permit icmp any any echo-reply
    access-list outside_access_in permit ip host Clark any
    access-list outside_access_in permit tcp any any eq 10000
    access-list outside_access_in permit udp any any eq 10000
    access-list inside_outbound_nat0_acl permit ip 192.168.6.0 255.255.255.0 Lexington 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip 192.168.6.0 255.255.255.0 VPN_Client 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip 192.168.6.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list outside_cryptomap_21 permit ip 192.168.6.0 255.255.255.0 Lexington 255.255.255.0
    access-list outside_cryptomap_21 permit ip 192.168.6.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list MyVoip permit tcp host 192.168.6.164 host X.X.X.X1 object-group port-RTP-tcp
    access-list MyVoip permit tcp host 192.168.6.164 host X.X.X.X1 object-group port-SIP-tcp
    access-list MyVoip permit udp host 192.168.6.164 host X.X.X.X1 object-group port-RTP-udp
    access-list MyVoip permit udp host 192.168.6.164 host X.X.X.X1 object-group port-SIP-udp
    access-list MyVoip permit tcp host 192.168.6.164 host X.X.X.X1 eq 2727
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside pppoe setroute
    ip address inside 192.168.6.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpnpool 192.168.145.1-192.168.145.5 mask 255.255.255.0
    pdm location Lexington 255.255.255.0 outside
    pdm location VPN_Client 255.255.255.0 outside
    pdm location Clark 255.255.255.255 outside
    pdm location 192.168.4.154 255.255.255.255 inside
    pdm location 192.168.6.156 255.255.255.255 inside
    pdm location 192.168.1.0 255.255.255.0 outside
    pdm location 192.168.6.164 255.255.255.255 outside
    pdm location 192.168.1.0 255.255.255.0 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface 10000 192.168.6.156 10000 netmask 255.255.255.255 0 0
    static (inside,outside) udp interface 10000 192.168.6.156 10000 netmask 255.255.255.255 0 0
    access-group MyVoip in interface outside
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.6.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set myset esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 10 set transform-set myset
    crypto map outside_map 21 ipsec-isakmp
    crypto map outside_map 21 match address outside_cryptomap_21
    crypto map outside_map 21 set peer x.x.x.x
    crypto map outside_map 21 set transform-set myset
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address x.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
    isakmp identity address
    isakmp nat-traversal 20
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption 3des
    isakmp policy 10 hash md5
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    vpngroup eavpn1 address-pool vpnpool
    vpngroup eavpn1 dns-server 192.0.1.31
    vpngroup eavpn1 wins-server 192.0.1.31
    vpngroup eavpn1 default-domain any.com
    vpngroup eavpn1 idle-time 1800
    vpngroup eavpn1 password ********
    telnet 0.0.0.0 0.0.0.0 outside
    telnet 192.168.6.0 255.255.255.0 inside
    telnet timeout 5
    ssh Clark 255.255.255.255 outside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 5
    management-access inside
    console timeout 0
    vpdn group PPPOEX request dialout pppoe
    vpdn group PPPOEX localname eliteky
    vpdn group PPPOEX ppp authentication pap
    vpdn username eliteky password *********
    dhcpd address 192.168.6.30-192.168.6.50 inside
    dhcpd dns 192.168.1.3
    dhcpd wins 192.0.1.31
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
    Cryptochecksum:485a43c0741d54b44b74016ab728e644
    : end
    [OK]



  • can you post your ipsec tunnel config from pfsense-side, are both sides static?

    racoon: ERROR: not acceptable Identity Protection mode –> maybe an MD5 or SHA problem in your config?



  • Heres the config of my tunnel.




  • it looks OK, why do you choose "aggressive" mode and not main mode, did you try for phase 1 a lifetime "28800" and phase 2 "86400"?
    Do you have tested it with SHA not MD5 and what errors shows the pix log?



  • I choose all of the following because that is what was required by the monowall instructions.



  • If you have on both sides static ip´s please test this as the  last slight hope, sorry but I haven´t a pix at the moment to duplicate your test



  • FWIW, I've had success connecting to PIX's without using no-xauth and no-config-mode
    eg-
    isakmp key ******** address x.x.x.x netmask 255.255.255.255

    I also didn't have
    isakmp identity address
    isakmp nat-traversal 20
    in my config. Otherwise similar- 6.3(5) on a 506



  • I've found a confirmation of what heiko said about the identification mode with a preshared key, in the source code
    ipsec_doi.c
    /* In main mode with pre-shared key, only address type can be used. */


Log in to reply