Problem to disable autoselect on WAN interface



  • Our provider requires to force  100 full duplex on the WAN interface.

    I did set the next option
    => System - Interfaces - WAN - Speed and Duplex, advanced - 100baseTX full-Duplex

    we still have bad inet performance though. The provider says this is due to duplex option is not manual set.

    Status - interfaces shows
    Media 100baseTX <full-duplex>which looks nice at a first glance I think.

    However: goin into the the shell ifconfig output shows
    media: Ethernet autoselect (100baseTX <full-duplex>)

    Is there a way to get rid of autoselect because this is probably causing the issue?

    ifconfig -m shows
    supported media
      media autoselect
      media 1000baseT
      media 1000baseT mediaopt full-duplex
      media 100baseTX mediaopt full-duplex
      media 100baseTX
      media 10baseT/UTP mediaopt full-duplex
      media 10baseT/UTP</full-duplex></full-duplex>


  • Banned

    Maybe get a non-idiotic ISP instead.



  • Thats not one of the options..



  • did you set the option and reboot?

    i've noticed that sometimes a reboot helps


  • Banned

    @fredvr:

    Thats not one of the options..

    Good luck with debugging non-issues and paying for that in addition to broken service, if that's the case…



  • @doktornotor
    It is not uncommon ISP requires no autonegotiation on the WAN interface. We had different ISP's and they all had that requirement.

    @heper
    Yes, pretty sure because after applying the setting from default to 100TX full-duplex there was an auto reboot (ooops)  and this is listed using ifconfig.
    It's also still reporting autoselect though while it shouldn't.

    in config.xml there are no <media>entries in the <interfaces><wan>settings.

    in the <interfaces><lan>it shows <media>autoselect</media> which is correct.

    not sure if I can just add effectively an  <media><mediaopt>  entry in config.xml using the shell whitout causing problems and what the correct settings should be for using 100base full-duplex to force a none autoselect situation on the wan interface</mediaopt></media></lan></interfaces></wan></interfaces></media>


  • Banned

    @fredvr:

    @doktornotor
    It is not uncommon ISP requires no autonegotiation on the WAN interface. We had different ISP's and they all had that requirement.

    Dude, maybe move to some sane area? Failing that, different country? Sorry, but an ISP suggesting that something is fixed by disabling autonegotiation just should go out of business.



  • was an auto reboot (ooops)

    perhaps you should investigate that … its not normal


  • Rebel Alliance Developer Netgate

    What type of NIC is used here?

    Some NICs like Realtek's re(4) interfaces claim to support media speed/duplex selection but actually fail to apply it at the hardware level on certain cards, notably the ones found in APU devices.

    In those cases your choices are to replace the NIC or put a managed switch between you and the upstream with the port facing pfSense set to auto, and the port facing the modem forced to 100/full



  • At last the problem seems to be 'solved'.

    It wasn't pfsense ;)

    The problem was in the ISP Cisco switch we are connecting to. As soon as Speed/Duplex is set to a fixed value (no autonegotiate) all port activity on the switch port stops..  No link, nothing.
    We discovered that using a x-cable at that time solves all problems:

    • autoselect => normal cable working, x-cable isn't
    • autoselect disabled => x-cable working, normal cable isn't

    :o :o

    Not sure if this is a configurable behaviour of the Cisco switch or a mallfunction thing. For now everythings works great though!


  • Banned

    @fredvr:

    The problem was in the ISP Cisco switch we are connecting to. As soon as Speed/Duplex is set to a fixed value (no autonegotiate) all port activity on the switch port stops..  No link, nothing.

    That's extremely "surprising". The idiots who claim themselves to be an ISP and tell you that disabling autonegotiation fixes things actually break it. Apparently they don't even know what kind of equipment they supply? Disabling autonegotiation is known to break MDI-X. Among other things. Your ISP == full retard.



  • Yep, that's also one of the things they teach at CCNA, disabling autonegotiation is never ever recommended.



  • Interesting fault between an X-cable and a straight-thru.  I will make myself a cross over and see how autoselect behaves on my WAN connection.  In my case, setting my WAN to default (which does properly auto negotiate) vs autoselect (erratic operation) makes a difference on my WAN for some very odd reason.