(SOLVE)Centos ntpdate: no server suitable for synchronization found


  • Hi.

    I have some wear issue, none of my centos boxes 5/6 want to use my pfsense box as a time source, every time I try to run I got:

    ntpdate no server suitable for synchronization found

    I try with debug mode and I got that my pfsense is to high:

    192.168.2.4: Server dropped: strata too high
    server 192.168.2.4, port 123
    stratum 16, precision -6, leap 11, trust 000
    refid [192.168.2.4], delay 0.04158, dispersion 56.00000
    transmitted 4, in filter 4

    If i check my pfsense I got that is stratum 2, if I wrong let me know please:

    pe
        remote          refid      st t when poll reach  delay  offset  jitter

    *142.54.181.202  64.113.32.5      2 u  433  512  305  400.040  33.622  22.461
    +74.91.27.139    199.102.46.72    2 u  656  512  226  413.423  33.744  12.089
    +96.44.142.5    200.98.196.212  2 u  190  512  377  55.657  200.754  6.126

    I got other ubuntu boxes, no issue there.

    Someone with issues like this one?

    pfsense 2.2.2 x64, I have other 2.2.4 and same issue.


  • You could try disabling the "Enable Kiss-o'-death packets" option under services/ntp/access restrictions.  I needed to do this to allow a nas4free box to use pfsense as a time server.  There may be a better way to do this, but it worked for me.

    Bill


  • wbond hahahaha that did the trick, thanks  ;D


  • I'm glad to hear it worked periko.

    If anyone knows why disabling KOD was necessary I'd be interested in hearing about it.


  • @wbond:

    I'm glad to hear it worked periko. 
    If anyone knows why disabling KOD was necessary I'd be interested in hearing about it.

    Not all Linux distro's are up to date. Might be a work around. http://www.ntp.org/ntpfaq/NTP-s-algo-crypt.htm


  • In my case the problem was with Nas4free which was built on FreeBSD 10.1 something at the time.  Not %100 of the version at the time I noticed it, but it was within the past month or so.