AMD A4-5000 temperature sensor



  • I just finished setting up a new ASRock QC-5000 which has an AMD A4-5000 CPU / APU.

    I set the temperature sensor to AMD in the settings page (ACPI doesn't work), but the temperature it shows doesn't seem to be correct. When I go to the BIOS settings and view the temperature, it shows it in them in the mid to high 40's. In pfsense, it shows the temperature in the mid to high 50s.

    It seems like it's not reading the temperature correctly, or the temperature needs to be adjusted for this CPU.

    Any suggestions on how I can fix this?

    Thanks.



  • Hi,

    i have also the ASRock QC5000M+32GB + Intel i350T4 + SSD  @ 21W att the moment.

    • AESNI + 4xPCIE
    • To high temp

    It's the vcore temp. you see on the web interface not the CPUtemp you see in BIOS
    Can go up more than 90°C and is not directly  the CPU temp. On Idle it is a -14° offset but changing on load

    I was in contact with ASRock because the high vcore temp (66°). on idle ~52°CPU temp  , they only said  the CPU temp. max is 90°C no answer about  vcore temp
    To keep the cpu cool on full load  i use a pull/push  fan in the near of the CPU paasive cooler and a additional case Fan .
    To keep it silent i set it up in bios for the  the 3PIN fan's : 0%->50°C,  50% -> 60°C, 75%->70°
    I tried powerd adaptive but there was no benefit for the vcore temp.

    If you want to try  "#powerd -v in consol first->my system is rebooting without disable acpi throttle first.

    edit /boot/loader.conf.local and reboot after save.

    powerd working with this entries:
    # Force EST for powerd
    hint.p4tcc.0.disabled=1
    hint.acpi_throttle.0.disabled=1

    If you want to lower the shown Temp:
    # AMD CPU Temp Offset
    #dev.amdtemp.0.sensor_offset="-14"

    And this is for the Intel NIC:
    _#Tuning Network see https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards#Intel_igb.284.29_and_em.284.29_Cards
    #Raise MBUF required for igb
    kern.ipc.nmbclusters="1000000"
    #Disable flow control for igb
    hw.igb.fc_setting="0"
    #raise irq rate for igb
    hw.igb.max_interrupt_rate="32000" _



  • Thanks for the response….

    For some reason, I couldn't get PowerD working on my setup. When I enabled it, pfsense would constantly reboot and I ended up having to reinstall the system.

    I also have 2 fans setup... one 120mm intake fan set to "quiet", and an 80mm exhaust fan also set to "quiet" mode in the BIOS.

    I will try some of the tweaks you mentioned and see how that goes.



  • Hi

    you are using a old pfsense version !
    pfsense 2.2.3 has a bug, kill files during filesystem check!
    Download & install pfsense 2.2.4  and you are save with yor filesystem when the  dirty bit is  set ;-)
    Was the same for my test before installing the new version. :o

    I don't like always running Fans, catching a lot of  dust …



  • I am actually running the latest version i.e. 2.2.4.

    Not sure why PowerD was causing it to constantly reboot. Wasn't worth the trouble trying to figure it out so I just reinstalled and left PowerD disabled.



  • Hi,

    now i understand, had the same trouble with reboot. This is why i said to try powerd from console  first :-)
    So once again if you want to try :

    In the webinterface open
    Diagnostic->Edit File
    In Diagnostics: Edit file press Browse, go with mouse(button)  to  boot then loader.conf.local now a white window is open, just copy and past there
    hint.acpi_throttle.0.disabled=1
    Now press button save and reboot.

    After reboot try dpowerd -v from shell if it works you can set this option via web


Log in to reply