Unbound Question



  • im trying to block/redirect some domains to localhost. in the DNS Resolver.

    When i manual add them to the domain overrides it works.
    but i got a WHOLE list and don't want to add them 1 by 1.

    What i have tried is.

    Made a list of the hosts like

    local-data: "services.wes.df.telemetry.microsoft.com A 127.0.0.1"
    local-data: "settings-sandbox.data.microsoft.com A 127.0.0.1"
    local-data: "sls.update.microsoft.com.akadns.net A 127.0.0.1"
    local-data: "sqm.df.telemetry.microsoft.com A 127.0.0.1"
    local-data: "sqm.telemetry.microsoft.com A 127.0.0.1"
    local-data: "sqm.telemetry.microsoft.com.nsatc.net A 127.0.0.1"

    put it in a file and called it microsoft.conf and put the file in /var/unbound
    Noting happens when i did that.

    i i tried it add a line in
    include: /var/unbound/microsoft.conf in the unbound.conf

    saved it and restarted unbound. But it does not keep the changes.

    When i add it those in the advanced settings and click save. It will restart unbound but it says down until i empty the list again and click on save.


  • Banned

    
    server:
    include: /var/unbound/microsoft.conf 
    
    


  • @doktornotor:

    
    server:
    include: /var/unbound/microsoft.conf 
    
    

    i did that.

    i added it under

    Access lists

    include: /var/unbound/access_lists.conf

    Static host entries

    include: /var/unbound/host_entries.conf

    dhcp lease entries

    include: /var/unbound/dhcpleases_entries.conf

    Domain overrides

    include: /var/unbound/domainoverrides.conf

    Remote Control Config

    include: /var/unbound/remotecontrol.conf

    server:
    include: /var/unbound/microsoft.conf


    like this. Then i restart unbound. but when i check the conf file its gone.

    Btw im using
    2.2.4-RELEASE (amd64)
    built on Sat Jul 25 19:57:37 CDT 2015
    FreeBSD 10.1-RELEASE-p15


  • Moderator

    You can't add to the conf file directly… You will need to enter that Server: Include: line in the "Adv." Settings Box in the Unbound GUI.



  • @BBcan177:

    You can't add to the conf file directly… You will need to enter that Server: Include: line in the "Adv." Settings Box in the Unbound GUI.

    ah GREAT that works :) Thx


Log in to reply