HE Tunnel and MTU of 1280



  • Hi there.. Im using 2.2.4-RELEASE (amd64)  and have a HE tunnel set up on my machine.. The tunnel is set for an MTU of 1480 on the tunnelbroker.net website, and I have entered an MTU of 1480 on my tunnel interface as well.. However, when I run ifconfig, it reports that the GIF interface MTU is at 1280.  If I run ifconfig eth0 mtu 1480, it will change and stick until a reboot.  Did I do something wrong, or is this a known issue?  Hardware is a Netgate RCC-VE 2440.


  • Banned

    This is not how you do it. Do NOT run ifconfig, use the GUI!

    
    gif0: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1472
            tunnel inet 192.0.2.30 --> 216.66.86.122
            inet6 2001:470:dead:beef::2 --> 2001:470:dead:beef::1 prefixlen 128
            inet6 fe80::225:22ff:fe9d:d9f1%gif0 prefixlen 64 scopeid 0x8
            nd6 options=21 <performnud,auto_linklocal></performnud,auto_linklocal></up,pointopoint,running,multicast> 
    


  • I probably should have clarified  (actually – I did originally :)  -- I do have an MTU of 1480 and MSS of 1460 entered in the GUI... The ifconfig was just for testing.

    gif0: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1280
            tunnel inet 104.148.xxx.xxx --> 209.51.161.xx
            inet6 2001:470:xxxx:xxx::2 --> 2001:470:xxxx:xxx::1 prefixlen 128
            inet6 fe80::208:a2ff:fe0x:xxxx%gif0 prefixlen 64 scopeid 0x9
            nd6 options=21 <performnud,auto_linklocal></performnud,auto_linklocal></up,pointopoint,running,multicast> 
    

  • Banned

    Cannot reproduce any such issue.

    
    grep -E 'mtu|mss' /cf/conf/config.xml
                            <mtu>1472</mtu>
                            <mss>1452</mss>
    
    


  • OK.. So here is what I discovered.. Upon a reboot, the MTU drops back to 1280, ignoring the values I had entered in the GUI… If I go to the interface and just do a save and apply after rebooting, the MTU then gets reported as 1480..

    Any ideas?



  • Can't see that neither:

    HEIPV6-Interface:

    gif0: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1472
            tunnel inet 109.222.174.27 --> 216.66.84.42
            inet6 2001:470:1f12:beef:dead::2 --> 2001:470:beef:dead::1 prefixlen 128
            inet6 fe80::2e0:4cff:fe80:4b18%gif0 prefixlen 64 scopeid 0x9
            nd6 options=21<performnud,auto_linklocal></performnud,auto_linklocal></up,pointopoint,running,multicast>
    

    Just thinking out loud : the mutu seems top me related  (can't be bigger then) to the interface 'above', so I give you mine:

    Btw: My uplink (WAN)

    pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
            inet 109.222.174.27 --> 193.253.160.3 netmask 0xffffffff
            inet6 fe80::2e0:4cff:fe80:4b18%pppoe0 prefixlen 64 scopeid 0x8
            nd6 options=21<performnud,auto_linklocal></performnud,auto_linklocal></up,pointopoint,running,noarp,simplex,multicast>
    

    running on a 'I shouldn't do that - but it never diedd on me" Realtek interface:

    rl0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=2008 <vlan_mtu,wol_magic>ether 00:e0:4c:80:4b:18
            inet6 fe80::2e0:4cff:fe80:4b18%rl0 prefixlen 64 scopeid 0x1
            inet 10.0.0.2 netmask 0xffffff00 broadcast 10.0.0.255
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active</full-duplex></performnud,auto_linklocal></vlan_mtu,wol_magic></up,broadcast,running,simplex,multicast>
    


  • For the two that kindly responded – do your user entered MTU values survive a reboot?  I tried deleting the OPT/GIF interfaces as well as the gateways and recreating, and I am still seeing the MTU revert back to 1280 after a reboot.  After rebooting, if I go to the interface that was assigned for the GIF, the MTU and MSS values appear there in the GUI properly -- but they will not be applied until I click SAVE.


  • Banned

    Doesn't revert anywhere here, as already noted. And no need to be clicking Save either.