NameCheap - A record not found



  • I'm setting up an ERP system (Odoo) behind pfSense with LXC and using HAProxy on pfSense. I have Dynamic DNS updating the IP address just fine (reporting a green state on the IP), the logs show that the NameCheap cache has been updated. However, when it gets to the part to update the A record, this error occurs: php-fpm[67249]: /services_dyndns_edit.php: phpDynDNS: (Error) No Records updated. A record not Found;.

    I followed the directions on the NameCheap site, the URL Redirect (@) is http://domain.info and the A record  is: www 127.0.0.1 A (Address). This is per their notes in the Dynamic DNS entry: Please make sure you create an A record for this host name before sending a dynamic dns update command. You can set an A record using the 'All Hosts' page. Use a dummy address if IP not known. ex: www 127.0.0.1 'A Record'

    Anyone else have this working? I searched the posts and see others whom had issues similar but got it working by unchecking wildcard in DynDNS (mine is unchecked).


  • LAYER 8 Global Moderator

    Working fine here.  I had not had this setup, but I do have a domain on namecheap so I went and created a pfsense host, with holder IP of 127.0.0.1

    I then did a query and validated hey their nameservers show that record and have my 127.0.0.1 address in it.

    Then setup pfsense to update namecheap

    Then did a query again and it shows correct address.  And from the logs looks good, even got my email notificatoin.






  • Just looked over my config and noticed I had a uid (versus what you had in your dyndns config). Took that out, applied the update, but still getting the /services_dyndns_edit.php: phpDynDNS: (Error) No Records updated. A record not Found;.

    Do you mind sharing what your Host settings look like on the NameCheap side? If they are the same as mine, then I'll shift my focus towards NameCheap as being the issue. Thank you very much for assisting me!


  • LAYER 8 Global Moderator

    dude this took all of 2 seconds to setup..  uid?  Clearly says not to put that in..

    I would assume you have the wrong record.. Why don't you query for your record.. What do you get back.. Should be your 127.0.0.1 you put in before you setup pfsense to update it.. If you can not qrery for the record then pfsense sure and the hell is not going to be able to update it.




  • I understand that it's quick to setup, had No-IP running for years and never ran into these issues. Below is what I have for my settings in NameCheap. Doing an nslookup returns 162.255.119.250, which is not my IP.

    I apologize if helping me is a burden on you, you don't have to reply. I'm just looking for a little guidance.

    ![Screenshot - 08312015 - 01:38:32 PM.png](/public/imported_attachments/1/Screenshot - 08312015 - 01:38:32 PM.png)
    ![Screenshot - 08312015 - 01:38:32 PM.png_thumb](/public/imported_attachments/1/Screenshot - 08312015 - 01:38:32 PM.png_thumb)


  • LAYER 8 Global Moderator

    well something is not right if your not getting back 127.0.0.1 when you query www.yourdomain.info

    Which is prob why your dyn update is failing.  Can you send me your domain name via PM or something and I can do a query direct to the name servers for namecheap.



  • Quick question, are you using an @ record with a domain that has a TLD with a period in it other than "co.uk", or an @ record off a subdomain like @.sub.domain.com?



  • Trel, my TLD is a .info. I've been forcing my connection through work so I'm outside my network, but still getting the same results.

    johnpoz, I'll send you the PM. Thank you!


  • LAYER 8 Global Moderator

    So five0va I just got your pm and did a test.. When I query the NS for that domain and then query it for your www record I get 127.0.0.1

    So seems like you have a problem with your dns that pfsense is using to find namecheap maybe and that is why your having issues trying to update something.  Or maybe you have a typo in the record your trying to update for the domain?

    I show your NS for that domain as

    ;; ANSWER SECTION:
    snipped.info.  1800    IN      NS      dns1.registrar-servers.com.
    snipped.info.  1800    IN      NS      dns3.registrar-servers.com.
    snipped.info.  1800    IN      NS      dns5.registrar-servers.com.
    snipped.info.  1800    IN      NS      dns2.registrar-servers.com.
    snipped.info.  1800    IN      NS      dns4.registrar-servers.com.

    ;; ANSWER SECTION:
    www.snipped.info. 1800  IN      A      127.0.0.1



  • @five0va:

    Trel, my TLD is a .info. I've been forcing my connection through work so I'm outside my network, but still getting the same results.

    johnpoz, I'll send you the PM. Thank you!

    Could you post the specific host/domain you're trying to update, you can mask it if you want, so something like

    So is your setup

    host: @
    domain: sub.domain.info

    or

    host: sub
    domain: domain.info

    or

    host: @
    domain: domain.info

    (I know in my case, I had to use the custom option and do this https://dynamicdns.park-your-domain.com/update?host=@&domain=<domain>&password=<password>&ip=%IP%
    because of https://redmine.pfsense.org/issues/4366 )</password></domain>



  • This is solved. Turns out that I needed to set 127.0.0.1 for both the records within NameCheap. Once I did that, my record updated just fine.


Log in to reply