SG-2220 won't boot



  • Hi!

    My brand new SG-2220 booted only twice.
    But now it hangs ( serial console is working):

    SeaBIOS (version SageBIOS-20150715_105142-localhost.localdomain)
    
    iPXE (http://ipxe.org) 00:14.0 C100 PCI2.10 PnP PMM+7FB80910+7FAE0910 C100
    
    iPXE (http://ipxe.org) 00:14.1 C200 PCI2.10 PnP PMM 7FB80910 7FAE0910 C200
    
    iPXE (http://ipxe.org) 00:14.2 C300 PCI2.10 PnP PMM 7FB80910 7FAE0910 C300
    
    iPXE (http://ipxe.org) 00:14.3 C400 PCI2.10 PnP PMM 7FB80910 7FAE0910 C400
    
    Press F12 for boot menu.
    
    F1  pfSense
    
    F6 PXE
    Boot:  F1
    |          
    

    Any suggestions?

    many thanks
    Günther



  • I have similar issues. I just received my brand SG-2220 but after installing PFSense it doesn't boot past the PFSense boot menu.
    However I do get past the bootloader, then it boots Multiuser and then it ends with "booting…".

    I've tried several options with the help of https://doc.pfsense.org/index.php/Boot_Troubleshooting but after the commands below it stays at the bootloader prompt.

    
    set console=comconsole
    boot -v
    
    

    I have the feeling it boots because after a few seconds the terminal freeze the nice LEDs go off one by one.



  • I solved my problem with the help of the OPNSense manual, at the bootloader is have set```
    set comconsole_port=0x2F8

    After booting go into the shell and add```
    set comconsole_port="0x2F8"
    ```to```
    /boot/loader.conf
    ```and save the file.


  • If you save those changes into a file named – loader.conf.local -- it will survive pfSense updates.
    The file does not exist so create one like this ee /boot/loader.conf.local

    So use ee or similar editor and add your console changes and save.



  • Those look similar to what is found here. Are you talking regular pfSense or the ADI version. I would think the ADI version has those covered..

    https://www.netgate.com/docs/rcc-dff-2220/freebsd.html