[Resolvido] Port Forward em FailOver parou de funcionar após atualização 2.2.4



  • Olá Comunidade do PFSENSE.

    Usei um PFSENSE ainda nas Versões 1.9xxxx, e configurei ele sem problemas, com tudo funcionando.
    Apenas ativei e configurei NAT / PORT FORWARD (Para aplicações básicas SSH - 22, TERMINAL SERVER - 3389, CAMERAS - 4500…, ETC), LINK FAILOVER com 1 Link Vivo PPPOE e outro Link NET IP DINÂMICO.
    Venho sempre atualizando as versões sem problema, mas ocorre que atualizei para a versão 2.2.4 e as regras de Firewall / Nat pararam de funcionar.
    Se eu tentar conectar remotamente de fora da empresa para dentro perdi todo acesso via putty (ssh), cameras e terminal Server,  mas se eu estiver na rede local interna tudo funciona normalmente.
    A única coisa que fiz  fora isso foi tirar os DNS do google e deixar os DNS das próprias conexões wans (vivo + net).
    Cheguei as regras e estão todas ok. Alguém tem uma luz de como descobrir o que ocorreu?
    Muito obrigado.



  • Olá Iconne, boa tarde.

    Vc tem Proxy instalado?

    Tenta habilitar a opção como da imagem anexa nas regras NAT.




  • Oi felipeborela

    Muito obrigado pelo retorno.

    Fiz esse procedimento mas não funcionou.




  • Iconne, boa tarde.

    Na foto que vc anexou o NAT Reflection não está selecionado a opção Enable NAT + Proxy.

    Seleciona essa opção, aplica as configurações e faz um teste.

    ;)



  • O Felipe, desculpe é que quando tirei o print já tinha voltado pra opção default. Mas fiz o teste sim com Nat Reflexion… segue imagem correta.
    Desculpe.

    ![Sem título.jpg](/public/imported_attachments/1/Sem título.jpg)
    ![Sem título.jpg_thumb](/public/imported_attachments/1/Sem título.jpg_thumb)



  • Ops, cortou a imagem em baixo mas foi selecionado sim.



  • Verifica no log do firewall para ver se a requisição esta sendo bloqueada pelo firewall.

    Pois tenho vários NAT funcinando na versao 2.2.4

    Suas WAN esta com o iP direto no pfsense ou tem o modem como router?



  • @reinaldo.feitosa:

    tenho vários NAT funcinando na versao 2.2.4

    Eu também.



  • @Iconne:

    mas ocorre que atualizei para a versão 2.2.4 e as regras de Firewall / Nat pararam de funcionar.

    Já conferiu se não definiu gateway nas regras da wan? Esse costuma ser um equivoco bem frequente…



  • Oi pessoal, desculpe a ausência.
    A dica do Reinaldo de olhar o modem ajudou a resolver o problema.
    O que ocorreu é que a NET fez uma troca de velocidade para 60MB no mesmo período que atualizei o sistema, e trocou também o modem, quando fui olhar as configurações do modem ele estava com as seguintes configurações:

    • Modem em modo router e não em modo bridge;
    • DHCP ativado dando ip de rede local (lan) para o servidor ao invês de dar ip wan;
    • Wan Block Traffic ativado para bloquear requisições;
    • E para completar tinha um DMZ ativo direcionado tráfego para um ip qualquer.

    Nem se o MagGyver descesse pessoalmente conseguiria funcionar com tudo isso.

    Valeu pela dica e ajuda pessoal. Agora tudo ok.



  • Um tcpdump matava a charada na primeira hora sem MagGyver  ou Chuck Norris


Log in to reply