Rc.conf_mount_rw periodic failures in logs



  • Since upgrading from 2.2.1 up to 2.2.4 I have noticed a recurring error message in the system logs.  This happens periodically on the hour.  The only thing I can think that might be switching to RW is the job that backups DHCP and RRD data.

    messages look like:
    php: rc.conf_mount_rw: The command '/sbin/mount -u -w -o sync,noatime /cf' returned exit code '1', the output was 'mount: /dev/ufs/cf: Device busy

    sometimes (but not always, seems to be about 1/3rd of the time) it is immediately followed by:
    php: rc.conf_mount_rw: File system is dirty. Launching FSCK for /

    Is this something to be concerned about?  Any way to get more data on what's going on?


  • Rebel Alliance Developer Netgate

    Login via ssh and try running /etc/rc.conf_mount_rw by hand, see what happens.

    When it's in ro mode (/etc/rc.conf_mount_ro) you can run "fsck -y /cf" to see if it can find/repair any errors.

    It could be that the disk is starting to give out.



  • Thanks for the response.

    I ran /etc/rc.conf_mount_rw via SSH - it returned successfully very fast.

    I then ran /etc/rc.conf_mount_ro - it took a few seconds, then also completed successfully (both commands verified by looking at the output from "mount")

    After the filesystem was mounted read only - I ran fsck -y /cf - and it produced the following result:

    ** /dev/ufs/cf
    ** Last Mounted on /cf
    ** Phase 1 - Check Blocks and Sizes
    ** Phase 2 - Check Pathnames
    ** Phase 3 - Check Connectivity
    ** Phase 4 - Check Reference Counts
    ** Phase 5 - Check Cyl groups
    33 files, 8520 used, 92535 free (39 frags, 11562 blocks, 0.0% fragmentation)

    ***** FILE SYSTEM IS CLEAN *****