Wifi Issues/DMA allocation errors



  • Hi

    I've got a RCC-VE 2440 board and a WLE200NX Wifi card and I got major WiFi issues. I played around with it a bit and figured out the following:

    • When inserting the WiFi card in the PCI slot at the back of the board (the one with the SIM card), the card is recognized and I can configure it, but I can't see the network. I tried with different WiFi analyzers, there's nothing detected.

    • When inserting the WiFi card in the PCI slot at the front, the card is recognized, I can set the system up and Wifi works, however the connection is not stable: It drops about one in 3 to 5 pings. I tired with different antennas, no luck. I also  switched off all other radio transmitters in the house. I get a lot of "out errors" on the Interface status page. I googled a bit and came across the athstats command. This one shows a lot of " tx failed 'cuz dma buffer allocation failed" and " tx frames with no ack marked" errors. I assume this is not normal. Could this be a dodgy Wifi card?

    Thanks for any help.

    Reto

    Interface status:

    WIFI interface (opt1, ath0)
    Status up
    MAC address 04:f0:21:16:93:b3
    IPv4 address 192.168.1.2
    Subnet mask IPv4 255.255.255.0
    IPv6 Link Local fe80::6f0:21ff:fe16:93b3
    MTU 1500
    Media autoselect mode 11ng <hostap>Channel 8
    SSID TEST
    BSSID cc:3a:61:48:b5:5a
    Rate 21M
    RSSI 10.0
    In/out packets 2287/484811 (298 KB/67.54 MB)
    In/out packets (pass) 2287/484811 (298 KB/67.54 MB)
    In/out packets (block) 97/0 (18 KB/0 bytes)
    In/out errors 11/226576
    Collisions 0
    Bridge (bridge0) learning

    [2.2.4-RELEASE][admin@pfSense.localdomain]/root: athstats
    athstats: ioctl: ath0: Invalid argument
    athstats: ioctl: ath0: Invalid argument
    18672        data frames received
    270498      data frames transmit
    99          tx frames with an alternate rate
    2150        short on-chip tx retries
    10456        long on-chip tx retries
    2186        tx failed 'cuz too many retries
    424          mib overflow interrupts
    3            stuck beacon conditions
    MCS12        current transmit rate
    227711      tx failed 'cuz dma buffer allocation failed
    263409      tx frames with no ack marked
    1876        tx frames with short preamble
    1420        rx failed 'cuz of bad CRC
    1            rx failed 'cuz frame too short
    51313        beacons transmitted
    174          periodic calibrations
    -0/+0        TDMA slot adjust (usecs, smoothed)
    39          rssi of last ack
    37          avg recv rssi
    -96          rx noise floor
    5213        tx frames through raw api
    414          A-MPDU sub-frames received
    6            CRC errors for non-last A-MPDU subframes
    1734        Frames transmitted with HT Protection
    218885      cabq frames transmitted
    42639        cabq xmit overflowed beacon interval
    Antenna profile:
    [0] tx  267812 rx        5
    [1] tx        0 rx    18667</hostap>


  • LAYER 8 Netgate

    Get an AP.  A real AP. One with an ethernet port and a radio or two. Don't know when ESF will purge this insanity.

    tx failed 'cuz too many retries
    tx failed 'cuz dma buffer allocation failed

    Any wonder why it doeznt w3rk?



  • I was thinking of getting a "real AP" if there's no easy solution to this. Just wondering if anyone else has similar issues.



  • I was thinking of getting a "real AP" if there's no easy solution to this.

    Yep this could be a really good chance for you.

    Just wondering if anyone else has similar issues.

    For sure they have because pfSense and WLAN are not even the best "friends"!
    You get it working well or you could get in trouble for ever and don´t manage it.

    There are often three miniPCIe slots inside, likes in the PC Engines APU or SG-xxxx units and;

    • the slot with the SIM cards is often reserved for modems (bonded to the SIM slot)
    • the slot near the SATA port(s) is reserved to the mSATAs (shared Port)
    • the other free slot is mostly free for usage likes WiFi and other cards

    So you see choosing the right slot is not only a game, then more a "must be".



  • Problem Solved:

    I got a new wifi card (it got a AR5B125 chip) and everything works perfect now, however it still doesn't work in the PCI slot with the SIM card (same issue as the original card, no errors, just no wifi singal).

    I guess the other card is defective.


Log in to reply