DNS Overrides not working on DHCP?



  • Hello everyone.

    I am using the DNS Resolver (unbound) in NON-forwarding mode. I have configured the DHCP server in pfSense with a different DNS server to hand out to DHCP clients, but the DHCP server stubbornly hands out its own interface IP instead for the DNS server.

    Screenshots attached showing the DHCP config screen along with the DHCP client results. Based on the descriptions and documentation I've read it would seem that this DHCP config should hand out the alternate DNS server entered, but that's not happening.

    How do I get the DHCP server to hand out a different DNS server than it's own self when the resolver is enabled? I have an internal DNS proxy filter that I want to run all DNS queries through and then have the proxy forward those queries on to the resolver.

    Thanks!




  • Netgate

    Are you sure that's not static in the client?



  • Positive it's not static. I'm getting the same result on multiple clients - all confirmed not statically assigned.

    More info: This is happening even with both the forwarder and resolver disabled. It seems the DHCP server is giving itself out as the DNS server even if it's not able to resolve or forward queries at all.

    I've tried manually deleting all DHCP leases and restarting the service multiple times. I can't seem to shake it's insistence on handing itself out as the DNS server.


  • Netgate

    Don't know.  Always works for me.  Another DHCP Server on the network perhaps?

    /var/dhcpd/etc/dhcpd.conf?  What's in the config for that subnet?

    I don't think it's obvious the DHCP server is handing out the wrong thing at all.  Wireshark it.



  • I rebooted the entire router and now it's working as expected. I guess something was just stuck so hard that only a hard reboot knocked it loose.