No default route



  • Hi

    I'm new to pfSense - I've just set it up on an old Intel D2500 mini-ITX board. It has 4GB RAM and I'm booting off USB flash. There are no other storage devices.

    I set it up by booting from the 64-bit USB live CD, and installed it to a second USB flash drive. Currently that's the only drive connected.

    I configured the LAN to be 192.168.1.254/24, and the WAN is PPPoE to my ISP. The only other change I made was to manually add some entries to /boot/loader.conf.local:

    
    legal.intel_iwi.license_ack=1
    legal.intel_ipw.license_ack=1
    
    

    based off some errors I saw in dmesg.

    My problem is that it doesn't set a default route, and networking doesn't work properly until I manually add it:

    route add default 81.187.81.187 # The remote end of my PPPoE connection
    

    How can I configure this correctly through the web UI so that it automatically gets added after a reboot? Currently I have to manually ssh in and add it after a reboot.

    Many thanks

    EDIT: this is 2.2.4 downloaded today. Also most of the log files in /var/log are 511488 bytes, and are padded with null characters (^@).


  • Netgate

    EDIT: this is 2.2.4 downloaded today. Also most of the log files in /var/log are 511488 bytes, and are padded with null characters (^@).

    They are circular log files.  If you're using the shell use the clog command to view them:

    clog system.log | grep string
    clog -f system.log (like tail -f system.log)

    Sorry I'm not familiar with PPPoE on pfSense.



  • Thanks, I didn't know about clog.

    An update: I have enabled ramdisk for /var and /tmp, which has generally improved the speed of e.g. 'vi'. Also, the gateway has started working even after a reboot! I'm not sure if it's because it's remembered and restored the route I added manually, or if it just needed another reboot after I configured the WAN entry.

    Anyway, it now seems to be working OK.



  • @evansj:

    Thanks, I didn't know about clog.

    An update: I have enabled ramdisk for /var and /tmp, which has generally improved the speed of e.g. 'vi'. Also, the gateway has started working even after a reboot! I'm not sure if it's because it's remembered and restored the route I added manually, or if it just needed another reboot after I configured the WAN entry.

    Anyway, it now seems to be working OK.

    you must be doing something wrong ….. are you running the full or memstick version?



  • Hi heper. Here's the full timeline:

    1. about 2 weeks ago I downloaded the CD .iso and tried to install it on my old mini-ITX system. This was a Via EPIA 800 with 512MB RAM and a 2GB CF card, that has been sat unused in my garage for the past 4 years.

    2. I was able to install it on the CF card but I had to disable DMA on all IDE ports. I also found that I had to manually create the default route after every reboot. I was suspicious that it was because my system was so ancient (I bought it in ~2002) so I decided to upgrade it.

    3. I ordered some replacement hardware for my mini-ITX case: an Intel Atom board with dual gigabit Ethernet (D2500CC), 4GB RAM, and a new USB flash stick to boot it off

    4. I got all of that set up today and again found that the default route wasn't added. That's when I posted my original message - I assumed it was the same as when I ran with the original board, i.e. it would lose the gateway on every boot

    5. After posting the message, I configured /tmp and /var to be on ramdisks using the UI, and rebooted. I expected to have to log in again and create the default route, but in fact it has added it automatically. So this must be either because it needed a reboot after first configuring the PPPoE connection (and I didn't do it), or it saved the default route I manually added and restored it automatically on boot.