Syslog-ng package cannot be updated or uninstalled



  • Hi all,

    When trying to either update or remove the syslog-ng package, I get this:

    Removing package...
    Starting package deletion for syslog-ng-3.6.2_3-amd64...done.
    Removing syslog-ng components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Deinstall commands... 
    
    

    and it just won't go away. Any idea what's going on here? How can I remove this package?

    Thanks!


  • Rebel Alliance Developer Netgate

    Is there an error somewhere near the very bottom of the page?

    It's attempting to run the package's deinstall command but it must be encountering a PHP error when it happens. You might try a reinstall of the package using the "xml" button and then try to uninstall it again.



  • Here's what I see whenever I try to reinstall/update/uninstall. The page stops loading as soon as it gets to "Deinstall commands… " and nothing else happens.

    Thanks for looking into this.




  • It stopped right here when I tried to reinstall just the XML as you suggested.



  • Banned

    @Pistolero:

    It stopped right here when I tried to reinstall just the XML as you suggested.

    Yeah, and? There is no problem with that, it's how it is supposed to work. It's finished, not sure what else are you expecting to happen there.


  • Rebel Alliance Developer Netgate

    Have you tried this again recently?

    If it's still broken, which version of pfSense are you running?



  • Just to get the info out - I had the same issue just now and reinstalling GUI component only helped - I was able to uninstall and then install Syslog-ng package again.
    Running full version - 2.2.4-RELEASE  (i386)


Log in to reply