Static ip on wan

  • OK i am getting frustrated here any help would be greatly appreciated.

    simple setup at least it should be!!
    one static ip from comcast                                static ip for wan pfsense box    /29 (right?)        subnet                                gateway

    thats wan settings                                lan ip for pfsense box    /24 (right?)    subnet      Set as gateway ? not sure here  i think thats what it uses if leave set as none correct? but either way should work

    lan settings                  google dns server          comcast dns server

    general settings  dns servers  with checked for sequential so it use googles first then comcasts for secondary.

    there has got be something i am missing somewhere because i have lookup issues. I can go to anyplace i want from lan computer as long as i do by ip.

    lan computer is a debian 8 setup standard install of lxde envioment.


  • The Wan settings look OK.

    The LAN settings don't need a Gateway entry, just leave it empty, it definitely won't work (the way you expect) with a Gateway set in LAN.

    Do you have DHCP turned on for your LAN?

  • yes dhcp is on for the lan am going to go test right now. back in hr or so with results.

    no joy i am going to factory reset and try it behind my router useing dhcp for wan and see if that works. doesn't really hurt if it double nat'ed for the use i am useing for but the one computer setup on this has to have internet.

    there has got to be a setting for dns somewhere other than in the genral settings

  • There are two places to look. One is the 'General Settings' you've already mentioned which sets the DNS for the pfSense. The other is in the DHCP settings (Services/DHCP Server), which is where you set the DNS servers for the clients on your LAN. If you have set your DNS correctly in both places, have you tried testing whether you can get out by setting a client's IP/DNS statically? If this works then maybe there is an issue with DHCP or possibly your internal network/switch setup.

  • but either way should work

    Nope.  Don't specify a gateway for LAN on the router.  In your client TCP/IP settings (eg. Windows, Linux), you need to tell it a gateway but you don't do that for your pfSense LAN port.  pfSense LAN Gateway should be blank.

  • Any interface on pfSense that has a gateway is considered as a WAN connection.

  • no if i set static ip and dns on client it has no effect.

  • Post screenshots of your WAN and LAN interfaces (Interfaces - WAN, LAN)

  • Ok thanks everyone i got that problem solved.

    If i setup wan and lan ports as i listed above minus the gateway entry for lan as explained by someone. everything works correctly on my netbook plugged into lan port.

    the moment i plug the actual client machine in that is on this lan it will not work i narrowed it down to i set a static dhcp lease for it.  If i reinstall pfsense the client machine works as expected until you set a static lease for it. dns for client machine is gone and will never come back until reinstall (i am sure there is a database somewhere you can delete to get rid of it andrebuild the database but i sure cant find it in docs or googleing.) be nice if there was way to delete a static dhcp lease but oh well.

    we lose power so much in this building i wanted to set static leases for clients on lan but if that kills dns for the one client that uses it then thats not option anymore.

    my question is if i set static ip on the clients does pfsense reconize and use them or does it have to be set dhcp on the client .

  • You're making an issue for yourself, something that works for hundreds of thousands of us, usng pfSEnse, doesn't work for you.

    As the mentionned "gateway-on-lan issue", totally not existent, even when looking it up in Google, but suddenly present on your system, this is pretty much the same thing.

    Static DHCP leases are setup in pfSense. Handle them, like creating, modify, delete them in the GUI, and all is well.
    There is no need to wipe some hiding database (btw : Google knows where this 'database' is, as soon as you use the correct word: config.xml).

    For some reason, most of us do not use a power-backup supply (UPS) for our pfSenbse boxes, and still things work very well. And yes, you are not the only one with power failures.

    So : the good news is: there is no problem.
    And if there is one : you made it up yourself, so : remove it, and you're ok ;)

    edit: using a static IP on the client (PC) which fells out of the network mask of pfSense will break the connection, that is normal.

Log in to reply