Intel X540-T2 10GBe link problems



  • Hello all,
    I have a PFsense box I've built up, it has a dual 10GBe using an Intel X540-T2 Dual Port 10GBase-T adapter (for IBM system X).
    PF Sense 2.2.4

    The drivers and everything load just fine, PFsense see's the two interfaces (IX0, IX1) etc and I can assign VLANs, rename etc in software like normal operation for both interfaces.

    However I cannot get IX0 to come up.
    I get no link lights for IX0 on the adapter card no matter what I plug it into or which cable I use (so it's not the cable or the port it's connected to. I've tried the card on another motherboard and the link lights do the same thing.

    I get link lights for ix1 (they also change colour depending on link connection speed) on the adapter card and PFsense shows a green arrow for interface up.

    Is there something special with the firmware in these cards that would limit only one interface to work when not used in an IBM system X? Or do I just have a dead card? Googling hasn't found me anything or maybe I'm no good at it.

    Is there any other testing I can do, or have I just purchased a bung card?

    Any info appreciated.



  • Solved.

    The board was poorly soldered and on close inspection was quite dirty. I did some reflow of the lead-free solder and gave the board a good cleaning and now it is working fine.



  • Got from eBay? I couldn't imagine ever soldering a device under warranty.