Slow download/upload speeds behind Firebox/Pfsense



  • Hello all,  setup a Watchguard Firebox X550e with an upgraded Celeron M processor 1300MHz  and 2gb of memory.  Currently im sitting at Pfsense 2.2.4-RELEASE (i386) and it appears to be doing the job.  My network looks like this:  1Gbps line from ISP to a gigabit switch (ISP needs this switch in place to get tv to work)  > Pfsense firewall > Dlink router > Gigabit Switch> computers.  When i do a fetch on a file from the pfsense box i get like 600kBps and when i do a speedtest connected to the pfsense im getting just about 350mbps.  If i connect one machine directly into the ISP's switch and do a speedtest, I get 985mbps which is close to what i pay for.  I have made sure:

    I have no packages/addons installed that would slow my bandwidth.
    I have no traffic shapers or limiters.
    I tried changing mtu to no avail on the WAN interface.
    I also checked that speed/duplex is set to default and also tried changing it to 1000baseT which no change.
    Also swapped cables, and even tried changing WAN port to a different physical port to no avail.

    Any ideas?  I would love to continue to use the firewall..but losing 2/3 of my bandwidth is pretty bad.  Let me know if you need any more information.



  • You show the DLink in line, have you tried removing that?



  • Yep,  wired my desktop straight to the interface on the firebox same issues.  Also tried replacing the ISP's switch with another one to see if that was the culprit but nope.



  • http://www.watchguard.com/products/core-e/compare.asp?p1=x550e&p2=x750e&p3=x1250e

    From the page:

    Performance
    Firewall Throughput 390 Mbps



  • Ah dang,  yep didnt catch that…...thanks for pointing it out!