10GB Intel ix0 panic when I enable MTU 9000



  • When I enable MTU over 9000 on the network cards I get a panic error. IT's the same exact issues as this post but the user resolved it without leaving how he did it.  running 2.15

    https://forum.pfsense.org/index.php?topic=53499.0



  • running 2.15

    then please update and try again



  • Yeah, by 10G standards you're running stone age drivers there. Upgrade.



  • but the user resolved it without leaving how he did it.

    Some things were named by him, perhaps you might be willing to try it out also?

    running 2.15

    Please update to the last available version 2.2.4, the 2.1.5 is based on FreeBSD 8.3
    and the 2.2.4 is based on FreeBSD 10.1 and so newer drivers were finding its way
    into the newer version.

    He did say:

    changed mbufs, re-enabled the onboard NIC's, did a few other things and it's working.

    Tuning and Troubleshooting Network Cards could provide one or more interesting things.



  • I have experience with x520-da2 adapters in my nas systems. With freebsd 9 i had to load external intel drivers and tweak ringbuffer settings to get it working.
    When i upgraded to freebsd 10.1 this was all working with included drivers, and needed no manual tweaks.

    Saw close to line speed with mtu 1500 and iperf, and copy speeds from spinning disk of 828MiB for 25TB volume with zfs send/receive using mbuffer. I saw no need to go to larger MTU, it did not make it faster for me. Only CPU load was little lower (Xeon e3-1220 in the nas units)