(Solved) OpenDNS DNS with Pfsense 2.2.4



  • Hello All,

    I am a beginner Pfsense user where my network is as such: (Internet) == (pfsense) == (lan users)

    I wish to use opendns: 208.67.220.123/208.67.222.123 for basic dns filtering.

    I am attaching the screenshot of my setup below. I have also followed the "Blocking DNS queries to external resolvers" guide but still my setup is not working.

    When I visit https://www.opendns.com/welcome/ or internetbadguys.com it says I am not using OpenDNS.

    Not sure what I am missing.

    Thanks,

    Pete.






  • Rebel Alliance Global Moderator

    And are you actually using the forwarder or the resolver?  Not going to use what you put in system dns if your using the resolver which is the new default out of the box with 2.2.4



  • I am using the resolver, with "Enable forwarding mode' = Unchecked

    Are you suggesting I use forwarder instead ?



  • Changing from Resolver to Forwarder did the trick.

    Thanks for the 'hint'

    See below attached files for the end result, which is what had been desired.





  • Banned

    Yeah, of course. With "Enable forwarding mode' = Unchecked in resolver, unbound just does recursive resolution itself, will never use anything in System - General.



  • @doktornotor:

    Yeah, of course. With "Enable forwarding mode' = Unchecked in resolver, unbound just does recursive resolution itself, will never use anything in System - General.

    Are you suggesting to use 'Resolver' with "Enable forwarding mode = Enabled" ? or just using forwarder sufficies ? My networking needs are simple as of now. I help manage a network in a small hotel/resort with varying userbase and primary criteria is to "Keep a tab on bandwidth by preventing users from accessing porn sites".


  • Banned

    Should work. Though, for this type of usage, the forwarder is just fine. You won't get any DNSSEC validation with OpenDNS anyway.