Restore on different hardware (NICs)



  • Hi there,

    we are preparing an old hardware as a "hot spare" in case our router hardware fails (x64).

    On the spare we got pfSense 2.2.4 (386) runnung but once we restore the original configuration the system breaks down and can't be recovered. Before it loads the required add-ons nicely but then collapses after reboot. Likely it has something to do with the bridges (NIC) are different than on the original (which is x64 by the way).

    Any workaround/idea?

    Thanks - Reinhard


  • Banned

    The idea is - edit the config backup and replace the references with matching interface names. (Manually. Do NOT run things like sed on it blindly. Will match certificates and whatnot…)



  • actually I tried that before but problem persists. Other than on original restore it does start loading the additional packages so perhaps this causes additional problems?


  • Banned

    Afraid "problem persists" is not useful description. Get console output.



  • Sorry ;-)

    Anyhow, I fixed it by using a x64 machine. In other words:

    Get the backup from the original, rename Interfaces in the XML File to different hardware and then restore it.

    Thanks for your help!

    Reinhard


Log in to reply