Soekris net6501 failed install from memstick



  • Hi there!

    Having trouble installing pfSense onto Soekris net6501 hardware.

    Successfully made and booted a USB stick from this image:

    pfSense-memstick-serial-2.2.4-RELEASE-i386.img

    The Soekris booted successfully, at 115200 baud, and I was able to enter the pfSense menu.

    USB stick successfully recognized as /dev/da0 device, and pfSense loaded just fine.

    Tried to install onto my 4GB SSD, which was successfully recognized as /dev/ada0 device.

    However, the installer got only this far, before stopping with this error:

    Executing `/sbin/bsdlabel -B -r -w ada0s1 auto'
    bsdlabel: /dev/ada0s1 read: Invalid argument

    After searching around online, I tried the dd command to wipe the SSD, in case there was anything unrecognizable on it from before (there shouldn't have been).

    Ran this command:

    dd if=/dev/zero of=/dev/ada0

    It successfully wiped the entire SSD (7732368 sectors, 3958972416 bytes, 1402 seconds, 2822454 bytes/second).  Then, I power cycled, and tried again.  It didn't help.

    Tried both "I" during boot, and "99" menu item, to run the installer, didn't make a difference.

    Tried both Easy Install and Custom Install options, didn't make a difference, it stopped at the same step.

    Now, I'm stumped.

    Any thoughts?

    Josh





  • Thanks, but I had seen all of those links already.

    I already did "dd" earlier, to completely clear the drive, so it wasn't a partitioning or GPT issue, or something left over from a previous installation.

    There's no SATA or AHCI options to set in the "BIOS" of the Soekris.  I think BSD is detecting the drives just fine, though, because they're all there, and the dd command completes without errors.  It honestly looks like some kind of scripting bug when it tries to do the partitioning.

    I found a workaround, though.

    Run the entire system from an external USB stick!  That's what I'm doing now.  The 4g-i386-nanobsd image works fine.

    Josh


Log in to reply