[SOLVED] : Configuration saved but not applied



  • Solution : The problem described bellow was caused by a package named "iperf" , by removing this package the problem was eliminated on both machines.

    Hey everyone.

    I am working with pfsense as a firewall to the internal network, producing all the needed connectivity.
    We had a really old server that runs the Pfsense, we decide to terminate that one and put it on a new one. So I made a full backup and apply that backup to a fresh installation of pfsense on a VMware(temporary) but it worked perfectly! Then the new hardware came and we moved the configuration setup from the VMware to a fresh installation of pfsense on the new hardware(final place for the pfsense) . Everything worked like it should, BUT! I add a new interface and setup a DHCP, but the interface does not provide IP's , today I try to add a new machine to one of the current networks, It did save the mapping but did not apply it to the new machien.

    I see that after the backup from another machine, any changes I do are saved in the configuration files but they are not applied by the system. I am suspecting a permissions problem, but I am not sure how can I check that.

    Version : 2.2.4-RELEASE (amd64)
    built on Sat Jul 25 19:57:37 CDT 2015
    FreeBSD 10.1-RELEASE-p15



  • UPDATE:

    I have reboot the system and all the configuration changes were executed. The new interface DHCP I have add before the restart worked like it should, I then had to changed the address and that update worked too. Now I have to change the address again, I changed it and reset the DHCP services, that did not made the DHCP to work properly, it keeps on providing the old address pool, but when I staticly enter the address, everything work like it should.
    The /var/dhcpd/etc/dhcpd.conf receive the proper configuration bur the deamon somehow does not read it ?



  • I have went back to the old machine that was working like it should, but apperantly the same thing happen to it as well.
    The only thing I did was remove tftp package. I bring it back afterwards but that did not change a thing.
    So I found post that brings a clue  - http://serverfault.com/questions/506592/pfense-needs-to-be-rebooted-to-effect-a-change-in-existing-nat

    So what I did was I run - /etc/rc.filter_configure_sync

    And then I check the system logs and I found the updates performed :
    Oct 22 13:11:42 php: rc.filter_configure_sync: Adding TFTP nat rules
    Oct 22 13:11:42 php: rc.filter_configure_sync: Adding TFTP nat rules

    So regardless of how much I run this, it always do that.
    I do have now problem with the TFTP, I have add another TFTP server and change the address to that TFTP server and the configuration its not working until I reboot the system.

    I have factory reset a machine with pfsense and try to change something on the DHCP , map an IP and no result till reboot.
    How I can fix this problem ?


Log in to reply