Pfsense install: Garbled screens



  • I'm installing 2.2.4 from USB to internal SSD in a netgate 4860.
    The install is controlled over a serial link.
    All goes well until I reach the screens referring to formatting & partitioning the destination drive
    At this point the screen display is partially garbled and the cursor behaves erratically.  See attached screen shot.
    All screens up until this point have displayed without problem.

    I've been researching this on Google, Pfsense forums, etc. but no joy.

    Any suggestions will be greatly appreciated (even if they show me to be a dummy.)

    I've attached a screen shot below.

    Regards,

    Michael
    ![Screen Shot 2015-09-26 at 16.56.07.png](/public/imported_attachments/1/Screen Shot 2015-09-26 at 16.56.07.png)
    ![Screen Shot 2015-09-26 at 16.56.07.png_thumb](/public/imported_attachments/1/Screen Shot 2015-09-26 at 16.56.07.png_thumb)



  • I've been seeing this ever since 2.2 came out. The fields still work correctly, they are just not displayed in the correct way. No idea why it hasn't been fixed.


  • Banned

    Already answered elsewhere. The problem is the terminal (settings) you are using, not the installer.


  • Rebel Alliance Developer Netgate

    There are some legit problems with bsdinstaller and graphical glitches like that (see https://redmine.pfsense.org/issues/4241 ) – we're going to be replacing bsdinstaller entirely soon so we don't want to waste too much effort attempting to fix its own problem.



  • The partitioning screen is also garbled.  Any suggestions for a work around?  This has me stopped in my tracks.


  • Rebel Alliance Developer Netgate

    The quick/easy install is the best method to use for now, though last time I tried I was able to make custom partitions but it took some care. Might be able to drop to a shell prompt and make the partitions with gpart first and then just pick them during the install.


Log in to reply